Import Debian changes 1.2.2-5.1 debian/1.2.2-5.1
authorKeith Packard <keithp@keithp.com>
Thu, 12 Apr 2018 17:31:23 +0000 (10:31 -0700)
committerBdale Garbee <bdale@gag.com>
Fri, 13 Apr 2018 20:54:58 +0000 (14:54 -0600)
freetts (1.2.2-5.1) unstable; urgency=medium

  * Non-maintainer upload.
  * build with openjdk-8 instead of default-jdk
  * Disable custom loadClass in VoiceManager

cleanup-script.sh [new file with mode: 0755]
debian/changelog
debian/control
debian/patches/disable-custom-loadclass.diff [new file with mode: 0644]
debian/patches/series
debian/rules

diff --git a/cleanup-script.sh b/cleanup-script.sh
new file mode 100755 (executable)
index 0000000..44f6b45
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+git rm -f lib/jsapi.exe lib/jsapi.sh lib/README.txt
+rm -f lib/jsapi.exe lib/jsapi.sh lib/README.txt
index 71f8f1f9e4a2055c2c731f08617c73d992408c85..13774ddac04206d914e2e880c48641d17b439a28 100644 (file)
@@ -1,3 +1,11 @@
+freetts (1.2.2-5.1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * build with openjdk-8 instead of default-jdk
+  * Disable custom loadClass in VoiceManager
+
+ -- Keith Packard <keithp@keithp.com>  Thu, 12 Apr 2018 10:31:23 -0700
+
 freetts (1.2.2-5) unstable; urgency=low
 
   * update to policy 4.1.3
 freetts (1.2.2-5) unstable; urgency=low
 
   * update to policy 4.1.3
index 1ac02a7cdbbd85215fe771d89b3fdfce60e55867..ddec8b8dfd40b77cb7751637bcb76b68c07b5dde 100644 (file)
@@ -1,7 +1,7 @@
 Source: freetts
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
 Source: freetts
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 9), default-jdk, ant, ant-optional, junit4, javahelper
+Build-Depends: debhelper (>= 9), openjdk-8-jdk, ant, ant-optional, junit4, javahelper
 Standards-Version: 4.1.3
 Section: java
 Vcs-Git: git://git.gag.com/debian/freetts
 Standards-Version: 4.1.3
 Section: java
 Vcs-Git: git://git.gag.com/debian/freetts
diff --git a/debian/patches/disable-custom-loadclass.diff b/debian/patches/disable-custom-loadclass.diff
new file mode 100644 (file)
index 0000000..af8e8c0
--- /dev/null
@@ -0,0 +1,31 @@
+Origin: https://sourceforge.net/p/freetts/discussion/137670/thread/938f4b85/
+Last-Update: 2018-04-12
+Description: Disable custom loadClass method
+ Custom loadClass in VoiceManager breaks under Java 9
+ .
+ freetts (1.2.2-5.1) unstable; urgency=low
+ .
+   * Disable custom loadClass in VoiceManager
+Author: Keith Packard <keithp@keithp.com>
+
+---
+
+--- freetts-1.2.2.orig/com/sun/speech/freetts/VoiceManager.java
++++ freetts-1.2.2/com/sun/speech/freetts/VoiceManager.java
+@@ -661,7 +661,7 @@ class DynamicClassLoader extends URLClas
+     /**
+      * {@inheritDoc}
+-     */
++     *
+     public Class loadClass(final String name)
+         throws ClassNotFoundException {
+         Class loadedClass = findLoadedClass(name);
+@@ -678,6 +678,7 @@ class DynamicClassLoader extends URLClas
+         }
+         return loadedClass;
+     }
++    */
+ }
+ /**
index 41287972a73f953d8a2794c0f120fe28e6422165..08a244a78be89cba6a2a45fa9f03269b740c9a25 100644 (file)
@@ -1,3 +1,4 @@
 license.terms-missing.diff
 debian-build-target.diff
 pulse-audio-compat.diff
 license.terms-missing.diff
 debian-build-target.diff
 pulse-audio-compat.diff
+disable-custom-loadclass.diff
index 5012469444a5ae2173cf9057c85a89b9b06eba3d..3004cfc23f1335cc486a4a5465e168a0e216f7d1 100755 (executable)
@@ -9,7 +9,7 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-export JAVA_HOME=/usr/lib/jvm/default-java
+export JAVA_HOME=/usr/lib/jvm/java-8-openjdk-amd64
 #export CLASSPATH=
 
 %:
 #export CLASSPATH=
 
 %: