fix paths to enable ia32 build on x86_64 host
authorBdale Garbee <bdale@gag.com>
Mon, 9 Nov 2009 16:12:34 +0000 (08:12 -0800)
committerBdale Garbee <bdale@gag.com>
Mon, 9 Nov 2009 16:12:34 +0000 (08:12 -0800)
debian/changelog
ia32/Makefile

index 9d3fa46cbf94aae71bb4182c5af3e8524b86f937..ab6abd674f3fec1fa682d393b84e922323452db4 100644 (file)
@@ -1,3 +1,9 @@
+elilo (3.12-2) UNRELEASED; urgency=low
+
+  * fix paths to support cross-building in ia32/Makefile, closes: #555153
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 09 Nov 2009 08:11:23 -0800
+
 elilo (3.12-1) unstable; urgency=low
 
   * new upstream version, closes: #376002
index dadffac96724c99787cd65badd49189df8ac1d35..c5f421b4ed8090833104dbc5b9c72bf8c9b50aab 100644 (file)
@@ -42,8 +42,8 @@ all: $(TARGET)
 system.o: rmswitch.h
 
 rmswitch.h: bin_to_h.c rmswitch.S
-       $(CC) -o bin_to_h bin_to_h.c
-       $(AS) -o rmswitch.o rmswitch.S
+       $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
+       $(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
        $(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
        ./bin_to_h <rmswitch >rmswitch.h