Imported Debian patch 3.12-3.1 debian/3.12-3.1
authorBen Hutchings <ben@decadent.org.uk>
Fri, 30 Jul 2010 17:32:03 +0000 (18:32 +0100)
committerBdale Garbee <bdale@gag.com>
Wed, 8 Sep 2010 20:53:34 +0000 (14:53 -0600)
16 files changed:
Makefile
choosers/Makefile
debian/changelog
debian/dirs
debian/elilo.initramfs-post-update [new file with mode: 0644]
debian/elilo.kernel-postinst [new file with mode: 0644]
debian/elilo.kernel-postrm [new file with mode: 0644]
debian/patches/debian-changes-3.12-3 [new file with mode: 0644]
debian/patches/series
debian/rules
devschemes/Makefile
fs/Makefile
ia32/Makefile
ia64/Makefile
tools/Makefile
x86_64/Makefile

index 98d032391fadc03e7dfaab1c8ed239e700f56b60..613b597ee890ac7d8c4b0034702cb74be251ac57 100644 (file)
--- a/Makefile
+++ b/Makefile
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/Make.defaults
-TOPDIR = $(SRCDIR)
+include Make.defaults
+TOPDIR=.
 
 
 CRTOBJS       = $(EFICRT0)/crt0-efi-$(ARCH).o
 LDSCRIPT      = $(EFICRT0)/elf_$(ARCH)_efi.lds
 
 LDFLAGS             += -T $(LDSCRIPT) -shared -Bsymbolic -L$(EFILIB) -L$(GNUEFILIB) $(CRTOBJS)
-LOADLIBES     = -lefi -lgnuefi $(shell $(CC) $(ARCH3264) -print-libgcc-file-name)
+LOADLIBES     = -lefi -lgnuefi $(shell $(CC) -print-libgcc-file-name)
 FORMAT        = efi-app-$(ARCH)
 
 FILESYSTEM    =
@@ -91,8 +87,7 @@ fileops.o : Make.defaults
 chooser.o : Make.defaults
 
 $(SUBDIRS): dummy
-       mkdir -p $@
-       $(MAKE) -C $@ -f $(SRCDIR)/../$@/Makefile SRCDIR=$(SRCDIR)/../$@ ARCH=$(ARCH)
+       $(MAKE) -C $@
 
 dummy:
 
@@ -111,4 +106,4 @@ ifeq ($(GCC_VERSION),2)
        @exit 1
 endif
 
-include $(SRCDIR)/Make.rules
+include Make.rules
index 7860cc84ed5ad9ac047759e124da01027cbee06a..31b10d09a48af693ffc21a26dd0820aa460c0768 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=
 
@@ -48,11 +43,11 @@ TARGET=choosers.o
 all: $(TARGET)
 
 $(TARGET): check-choosers $(TOPDIR)/Make.defaults $(FILES)
-       $(LD) $(LD3264) -o $@ -r $(FILES)
+       $(LD) -o $@ -r $(FILES)
 
 clean:
        $(RM) -f $(TARGET) $(FILES)
-
+       
 check-choosers:
        @if [ -n "$(FILES)" ]; then \
                exit 0; \
index 8b73e9dfcebfc1045701f19887eb8fc5c65281bf..fb2ce99c6abc1e82ffd3077d27e133248cc5636d 100644 (file)
@@ -1,3 +1,11 @@
+elilo (3.12-3.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Add kernel and initramfs hook scripts to ensure elilo is reinstalled
+    whenever the kernel or initramfs is updated. closes: #590023
+
+ -- Ben Hutchings <ben@decadent.org.uk>  Fri, 30 Jul 2010 18:32:03 +0100
+
 elilo (3.12-3) unstable; urgency=low
 
   * fix paths and options to build both 32 and 64 bit versions on either
index 11174f44f89dc1b4bc7a9bd1c55c4abc16de2ab0..76bd9e257c1cc30e13f90df54393b9634339fcd8 100644 (file)
@@ -1,2 +1,5 @@
+etc/initramfs/post-update.d
+etc/kernel/postinst.d
+etc/kernel/postrm.d
 usr/lib/elilo
 usr/sbin
diff --git a/debian/elilo.initramfs-post-update b/debian/elilo.initramfs-post-update
new file mode 100644 (file)
index 0000000..66bcbb1
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh
+case "$DPKG_MAINTSCRIPT_PACKAGE" in
+    linux-image-*)
+       # elilo will be updated later by the kernel postinst hook; no
+       # need to update it now.
+       exit 0
+       ;;
+    *)
+       elilo </dev/null >&2
+       ;;
+esac
diff --git a/debian/elilo.kernel-postinst b/debian/elilo.kernel-postinst
new file mode 100644 (file)
index 0000000..0b8c944
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+elilo </dev/null >&2
diff --git a/debian/elilo.kernel-postrm b/debian/elilo.kernel-postrm
new file mode 100644 (file)
index 0000000..9cfff17
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+# Do not abort kernel removal in case of error
+elilo </dev/null >&2 || true
diff --git a/debian/patches/debian-changes-3.12-3 b/debian/patches/debian-changes-3.12-3
new file mode 100644 (file)
index 0000000..f632a23
--- /dev/null
@@ -0,0 +1,284 @@
+Description: Upstream changes introduced in version 3.12-3
+ This patch has been created by dpkg-source during the package build.
+ Here's the last changelog entry, hopefully it gives details on why
+ those changes were made:
+ .
+ elilo (3.12-3) unstable; urgency=low
+ .
+   * fix paths and options to build both 32 and 64 bit versions on either
+     flavor of build host, closes: #574713
+   * don't generate noise when following symlink since that's now the normal
+     situation, closes: #581068
+ .
+ The person named in the Author field signed this changelog entry.
+Author: Bdale Garbee <bdale@gag.com>
+Bug-Debian: http://bugs.debian.org/574713
+Bug-Debian: http://bugs.debian.org/581068
+
+---
+The information above should follow the Patch Tagging Guidelines, please
+checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
+are templates for supplementary fields that you might want to add:
+
+Origin: <vendor|upstream|other>, <url of original patch>
+Bug: <url in upstream bugtracker>
+Bug-Debian: http://bugs.debian.org/<bugnumber>
+Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
+Forwarded: <no|not-needed|url proving that it has been forwarded>
+Reviewed-By: <name and email of someone who approved the patch>
+Last-Update: <YYYY-MM-DD>
+
+--- elilo-3.12.orig/Makefile
++++ elilo-3.12/Makefile
+@@ -25,15 +25,19 @@
+ # to use this program.
+ #
+-include Make.defaults
+-TOPDIR=.
++SRCDIR = .
++
++VPATH = $(SRCDIR)
++
++include $(SRCDIR)/Make.defaults
++TOPDIR = $(SRCDIR)
+ CRTOBJS       = $(EFICRT0)/crt0-efi-$(ARCH).o
+ LDSCRIPT      = $(EFICRT0)/elf_$(ARCH)_efi.lds
+ LDFLAGS            += -T $(LDSCRIPT) -shared -Bsymbolic -L$(EFILIB) -L$(GNUEFILIB) $(CRTOBJS)
+-LOADLIBES     = -lefi -lgnuefi $(shell $(CC) -print-libgcc-file-name)
++LOADLIBES     = -lefi -lgnuefi $(shell $(CC) $(ARCH3264) -print-libgcc-file-name)
+ FORMAT        = efi-app-$(ARCH)
+ FILESYSTEM    =
+@@ -87,7 +91,8 @@ fileops.o : Make.defaults
+ chooser.o : Make.defaults
+ $(SUBDIRS): dummy
+-      $(MAKE) -C $@
++      mkdir -p $@
++      $(MAKE) -C $@ -f $(SRCDIR)/../$@/Makefile SRCDIR=$(SRCDIR)/../$@ ARCH=$(ARCH)
+ dummy:
+@@ -106,4 +111,4 @@ ifeq ($(GCC_VERSION),2)
+       @exit 1
+ endif
+-include Make.rules
++include $(SRCDIR)/Make.rules
+--- elilo-3.12.orig/devschemes/Makefile
++++ elilo-3.12/devschemes/Makefile
+@@ -23,10 +23,15 @@
+ # to use this program.
+ #
+-include ../Make.defaults
+-include ../Make.rules
++SRCDIR = .
++
++VPATH = $(SRCDIR)
++
++include $(SRCDIR)/../Make.defaults
++include $(SRCDIR)/../Make.rules
++
++TOPDIR=$(SRCDIR)/..
+-TOPDIR=$(CDIR)/..
+ FILES=simple.o
+@@ -40,7 +45,7 @@ all: $(TARGET)
+ #      without doing make clean.
+ #
+ $(TARGET): $(FILES)
+-      $(LD) -r -o $@ $(FILES)
++      $(LD) $(LD3264) -r -o $@ $(FILES)
+ clean:
+       $(RM) -f $(TARGET) $(FILES)
+--- elilo-3.12.orig/ia64/Makefile
++++ elilo-3.12/ia64/Makefile
+@@ -23,10 +23,15 @@
+ # to use this program.
+ #
+-include ../Make.defaults
+-include ../Make.rules
++SRCDIR = .
++
++VPATH = $(SRCDIR)
++
++include $(SRCDIR)/../Make.defaults
++include $(SRCDIR)/../Make.rules
++
++TOPDIR=$(SRCDIR)/..
+-TOPDIR=$(CDIR)/..
+ FILES=system.o config.o fpswa.o plain_loader.o gzip_loader.o \
+       gzip.o memset.o memcpy.o setjmp.o longjmp.o
+--- elilo-3.12.orig/choosers/Makefile
++++ elilo-3.12/choosers/Makefile
+@@ -23,10 +23,15 @@
+ # to use this program.
+ #
+-include ../Make.defaults
+-include ../Make.rules
++SRCDIR = .
++
++VPATH = $(SRCDIR)
++
++include $(SRCDIR)/../Make.defaults
++include $(SRCDIR)/../Make.rules
++
++TOPDIR=$(SRCDIR)/..
+-TOPDIR=$(CDIR)/..
+ FILES=
+@@ -43,11 +48,11 @@ TARGET=choosers.o
+ all: $(TARGET)
+ $(TARGET): check-choosers $(TOPDIR)/Make.defaults $(FILES)
+-      $(LD) -o $@ -r $(FILES)
++      $(LD) $(LD3264) -o $@ -r $(FILES)
+ clean:
+       $(RM) -f $(TARGET) $(FILES)
+-      
++
+ check-choosers:
+       @if [ -n "$(FILES)" ]; then \
+               exit 0; \
+--- elilo-3.12.orig/ia32/Makefile
++++ elilo-3.12/ia32/Makefile
+@@ -23,10 +23,15 @@
+ # to use this program.
+ #
+-include ../Make.defaults
+-include ../Make.rules
++SRCDIR = .
++
++VPATH = $(SRCDIR)
++
++include $(SRCDIR)/../Make.defaults
++include $(SRCDIR)/../Make.rules
++
++TOPDIR=$(SRCDIR)/..
+-TOPDIR=$(CDIR)/..
+ FILES=system.o config.o bzimage.o plain_loader.o gzip_loader.o gzip.o
+@@ -37,13 +42,13 @@ all: $(TARGET)
+ system.o: rmswitch.h
+ rmswitch.h: bin_to_h.c rmswitch.S
+-      $(CC) -o bin_to_h bin_to_h.c
+-      $(AS) -o rmswitch.o rmswitch.S
++      $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
++      $(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
+       $(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
+       ./bin_to_h <rmswitch >rmswitch.h
+ $(TARGET): $(FILES)
+-      $(LD) -r -o $@ $(FILES)
++      $(LD) $(LD3264) -r -o $@ $(FILES)
+ clean:
+       $(RM) -f $(TARGET) $(FILES)
+--- elilo-3.12.orig/x86_64/Makefile
++++ elilo-3.12/x86_64/Makefile
+@@ -23,10 +23,15 @@
+ # to use this program.
+ #
+-include ../Make.defaults
+-include ../Make.rules
++SRCDIR = .
++
++VPATH = $(SRCDIR)
++
++include $(SRCDIR)/../Make.defaults
++include $(SRCDIR)/../Make.rules
++
++TOPDIR=$(SRCDIR)/..
+-TOPDIR=$(CDIR)/..
+ FILES=system.o config.o bzimage.o plain_loader.o gzip_loader.o gzip.o
+ #FILES=system.o config.o plain_loader.o
+@@ -38,13 +43,13 @@ all: $(TARGET)
+ system.o: rmswitch.h
+ rmswitch.h: bin_to_h.c rmswitch.S
+-      $(CC) -o bin_to_h bin_to_h.c
+-      $(AS) -o rmswitch.o rmswitch.S
++      $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
++      $(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
+       $(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
+       ./bin_to_h <rmswitch >rmswitch.h
+ $(TARGET): $(FILES)
+-      $(LD) -r -o $@ $(FILES)
++      $(LD) $(LD3264) -r -o $@ $(FILES)
+ clean:
+       $(RM) -f $(TARGET) $(FILES)
+--- elilo-3.12.orig/tools/Makefile
++++ elilo-3.12/tools/Makefile
+@@ -23,10 +23,15 @@
+ # to use this program.
+ #
+-include ../Make.defaults
+-include ../Make.rules
++SRCDIR = .
++
++VPATH = $(SRCDIR)
++
++include $(SRCDIR)/../Make.defaults
++include $(SRCDIR)/../Make.rules
++
++TOPDIR=$(SRCDIR)/..
+-TOPDIR=$(CDIR)/..
+ FILES=eliloalt.o
+ TARGET=eliloalt
+--- elilo-3.12.orig/fs/Makefile
++++ elilo-3.12/fs/Makefile
+@@ -23,10 +23,15 @@
+ # to use this program.
+ #
+-include ../Make.defaults
+-include ../Make.rules
++SRCDIR = .
++
++VPATH = $(SRCDIR)
++
++include $(SRCDIR)/../Make.defaults
++include $(SRCDIR)/../Make.rules
++
++TOPDIR=$(SRCDIR)/..
+-TOPDIR=$(CDIR)/..
+ FILES=
+ ifeq ($(CONFIG_localfs),y)
+@@ -55,7 +60,7 @@ all: $(TARGET)
+ #      without doing make clean.
+ #
+ $(TARGET): check-filesystems $(TOPDIR)/Make.defaults $(FILES)
+-      $(LD) -r -o $@ $(FILES)
++      $(LD) $(LD3264) -r -o $@ $(FILES)
+ clean:
+       $(RM) -f $(TARGET) $(FILES)
index 80f5939f9a3cc3ec9329e03226bfa1c31c3c079a..7ed73bc573af34df86aed125d8f561bc9ab35af6 100644 (file)
@@ -1 +1,2 @@
 fix-paths.diff
+debian-changes-3.12-3
index be2c8ffaaa4beffd74aa4fa50a75226fd3cb1696..eae4874d8a3ddaa0c99a340703b37f50897d8b1b 100755 (executable)
@@ -73,6 +73,14 @@ endif
        cp tools/eliloalt debian/elilo/usr/sbin/eliloalt
        chmod 0755 debian/elilo/usr/sbin/eliloalt
 
+       cp debian/elilo.initramfs-post-update \
+               debian/elilo/etc/initramfs/post-update.d/elilo
+       cp debian/elilo.kernel-postinst \
+               debian/elilo/etc/kernel/postinst.d/zz-elilo
+       cp debian/elilo.kernel-postrm \
+               debian/elilo/etc/kernel/postrm.d/zz-elilo
+       chmod 755 debian/elilo/etc/initramfs/*.d/* debian/elilo/etc/kernel/*.d/*
+
 binary-indep: build install
 
 binary-arch: build install
index 5328cb1a46cf0c6ab9573817a1cc093366bbb0ad..6ac05af77a83f29ab2a138528cb1144c68d07ff5 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=simple.o
 
@@ -45,7 +40,7 @@ all: $(TARGET)
 #      without doing make clean.
 #
 $(TARGET): $(FILES)
-       $(LD) $(LD3264) -r -o $@ $(FILES)
+       $(LD) -r -o $@ $(FILES)
 
 clean:
        $(RM) -f $(TARGET) $(FILES)
index 4c26f713ea9f4563b77916605c276eadb088ac94..1829d967cee4edfd9b50389c58b82e14b4fd4b13 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=
 ifeq ($(CONFIG_localfs),y)
@@ -60,7 +55,7 @@ all: $(TARGET)
 #      without doing make clean.
 #
 $(TARGET): check-filesystems $(TOPDIR)/Make.defaults $(FILES)
-       $(LD) $(LD3264) -r -o $@ $(FILES)
+       $(LD) -r -o $@ $(FILES)
 
 clean:
        $(RM) -f $(TARGET) $(FILES)
index c5f421b4ed8090833104dbc5b9c72bf8c9b50aab..353ae6791dffb98d8803a5ee148d313d01e09fee 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=system.o config.o bzimage.o plain_loader.o gzip_loader.o gzip.o
 
@@ -42,13 +37,13 @@ all: $(TARGET)
 system.o: rmswitch.h
 
 rmswitch.h: bin_to_h.c rmswitch.S
-       $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
-       $(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
+       $(CC) -o bin_to_h bin_to_h.c
+       $(AS) -o rmswitch.o rmswitch.S
        $(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
        ./bin_to_h <rmswitch >rmswitch.h
 
 $(TARGET): $(FILES)
-       $(LD) $(LD3264) -r -o $@ $(FILES)
+       $(LD) -r -o $@ $(FILES)
 
 clean:
        $(RM) -f $(TARGET) $(FILES)
index bee0a2bbd9615311bf00ff89fa0933ad1985e503..a243d0f5bbaf360a7d0e39863917bb43680840c3 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=system.o config.o fpswa.o plain_loader.o gzip_loader.o \
       gzip.o memset.o memcpy.o setjmp.o longjmp.o
index 97083d79a1999337e1dd37f9aaeb349578e8360d..88582242ad26921b9e515d96e9eca9875ce94bfd 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=eliloalt.o
 TARGET=eliloalt
index 7ade312780dedf7f4ad9ceb20f7c448c92ea3f44..4af4b8d9448cec31ac7fe906d2fdef5903ca6ac1 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=system.o config.o bzimage.o plain_loader.o gzip_loader.o gzip.o
 #FILES=system.o config.o plain_loader.o
@@ -43,13 +38,13 @@ all: $(TARGET)
 system.o: rmswitch.h
 
 rmswitch.h: bin_to_h.c rmswitch.S
-       $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
-       $(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
+       $(CC) -o bin_to_h bin_to_h.c
+       $(AS) -o rmswitch.o rmswitch.S
        $(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
        ./bin_to_h <rmswitch >rmswitch.h
 
 $(TARGET): $(FILES)
-       $(LD) $(LD3264) -r -o $@ $(FILES)
+       $(LD) -r -o $@ $(FILES)
 
 clean:
        $(RM) -f $(TARGET) $(FILES)