fix bashisms in example script
authorBdale Garbee <bdale@gag.com>
Fri, 29 Aug 2008 14:51:52 +0000 (08:51 -0600)
committerBdale Garbee <bdale@gag.com>
Fri, 29 Aug 2008 14:51:52 +0000 (08:51 -0600)
debian/changelog
examples/dump_on_cd_3/dump_disk

index 13c11293b9b520a7fd64e22e5378ebb29e24218f..a09ce4e3edd448fd9995d1125926122e2a5b6466 100644 (file)
@@ -1,3 +1,10 @@
+dump (0.4b41-6) unstable; urgency=high
+
+  * increase urgency since this minor fix would be good for lenny
+  * fix bashisms in example shell script, closes: #489570
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 29 Aug 2008 08:51:32 -0600
+
 dump (0.4b41-5) unstable; urgency=low
 
   * eliminate debian/po in the source tree since it is no longer relevant,
index 3e9200da803da7c5896d4d73153a6d289c303112..37041b2780412b148914f5f43ef1c722a73f1480 100755 (executable)
@@ -55,14 +55,14 @@ write_output() {
        while [ "$ANSWER" != "y" ] ; do
                echo -n "Is the disk ready? (y/n) "
                read  </dev/tty ANSWER
-               if [ "$ANSWER" == "y" ] ; then
+               if [ "$ANSWER" = "y" ] ; then
                        (${RECORD_BIN}${1}) &
                        return 0
-               elif [ "$ANSWER" == "n" ] ; then
+               elif [ "$ANSWER" = "n" ] ; then
                        EXIT=""
                        echo -n "Do you really want to exit? (y/n) "
                        read </dev/tty EXIT
-                       if [ "$EXIT" == "y" ] ; then
+                       if [ "$EXIT" = "y" ] ; then
                                return 1
                        fi
                fi