Imported Debian patch 0.4b41-2 debian/0.4b41-2
authorBdale Garbee <bdale@gag.com>
Fri, 6 Jan 2006 03:13:45 +0000 (20:13 -0700)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 05:04:31 +0000 (23:04 -0600)
debian/changelog
debian/postrm

index f3f818c05dd44fec8891761c6120591e96a6e698..2b7fe6c594c6806ac3b29f5348c74b6d10a3e663 100644 (file)
@@ -1,3 +1,9 @@
+dump (0.4b41-2) unstable; urgency=low
+
+  * fix postrm to only remove dumpdates file on purge, closes: #346142
+
+ -- Bdale Garbee <bdale@gag.com>  Thu,  5 Jan 2006 20:13:45 -0700
+
 dump (0.4b41-1) unstable; urgency=low
 
   * new upstream version
index f5ca1ce0966bed4b616b9beb52c6f81edfc3a27c..822abeb2de7a82b494f4a953e7a9630e739f1b92 100644 (file)
@@ -1,5 +1,16 @@
 #!/bin/sh -e
 
-rm -f /var/lib/dumpdates
+case "$1" in
+       purge)
+               rm -f /var/lib/dumpdates
+       ;;
+
+       remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
+       ;;
+
+       *)
+               echo "postrm called with unknown argument \`$1'" >&2
+               exit 1
+esac
 
 #DEBHELPER#