another try at getting stripping right
authorBdale Garbee <bdale@gag.com>
Thu, 16 Feb 2023 04:17:17 +0000 (21:17 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 16 Feb 2023 04:17:17 +0000 (21:17 -0700)
debian/changelog
debian/rules

index ccd0a2317a4da73e6368c2e55042245c765e3c88..095c61effacd3a8ace77d978c706cae04a8b2975 100644 (file)
@@ -1,3 +1,10 @@
+cpmtools (2.23-3) unstable; urgency=low
+
+  * force override of install program to address unwanted stripping,
+    closes: #1029084
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 15 Feb 2023 20:57:37 -0700
+
 cpmtools (2.23-3) unstable; urgency=low
 
   * try harder to get build using libdsk, closes: #1027769
index 917f34796e62a34de1f1c63b961b6866879969e8..7788bcdbc15314d063c25737932f3ed5fed70de5 100755 (executable)
@@ -5,3 +5,10 @@
 
 override_dh_auto_configure:
        dh_auto_configure -- --datarootdir=/etc/cpmtools --with-libdsk=/usr
+
+override_dh_auto_install:
+       make install \
+               DESTDIR=$(CURDIR)/debian/cpmtools \
+               AM_UPDATE_INFO_DIR=no \
+               'INSTALL=install --strip-program=true'
+