update hardening build flags config debian/2.9.0-4
authorBdale Garbee <bdale@gag.com>
Wed, 26 Mar 2014 01:41:17 +0000 (18:41 -0700)
committerBdale Garbee <bdale@gag.com>
Wed, 26 Mar 2014 01:41:17 +0000 (18:41 -0700)
debian/rules

index 171c82a56672df9e6e2f7811635800378dfdc144..51fd9ae51c122f9efc3444003973f8b8f7b35d75 100755 (executable)
@@ -9,10 +9,12 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 export HOME=$(CURDIR)/build
 
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
 CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
-CFLAGS += -Wall -Wno-comment
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
 LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
-CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+
+CFLAGS += -Wall -Wno-comment
 
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g -O0