lose more stuff we don't actually need from the package
authorBdale Garbee <bdale@gag.com>
Mon, 11 Jun 2012 02:16:26 +0000 (20:16 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 11 Jun 2012 02:16:26 +0000 (20:16 -0600)
debian/cc1111.install
debian/rules

index 8e5f1fa4cefd8dfbc92cb30696eed4a1141daffb..c62f9ec355af870cd8d42150185a9cd6635c9035 100644 (file)
@@ -13,6 +13,6 @@ usr/share/sdcc/lib/
 usr/bin/s51
 usr/bin/sdcdb
 usr/bin/*.el usr/share/emacs/site-lisp/sdcc-ucsim/
-usr/share/doc/ucsim/*.html usr/share/doc/sdcc-ucsim/
-usr/share/doc/ucsim/*.gif  usr/share/doc/sdcc-ucsim/
-usr/share/doc/ucsim/*.jpg  usr/share/doc/sdcc-ucsim/
+usr/share/doc/ucsim/*.html usr/share/doc/cc1111/
+usr/share/doc/ucsim/*.gif  usr/share/doc/cc1111/
+usr/share/doc/ucsim/*.jpg  usr/share/doc/cc1111/
index 9913097f7f809bfc828f9c4cc19f025a939ed91e..34ba6db1862a089a73366f6f018ee3ea5e08a21a 100755 (executable)
@@ -97,7 +97,6 @@ install-stamp: build
        mv debian/tmp/usr/share/doc/sdcc/* debian/tmp/usr/share/doc/cc1111/
        # Add some scripts
        mkdir -p debian/tmp/usr/share/sdcc/scripts
-       install -o root -g root -m 755  support/scripts/inc2h-pic16.pl debian/tmp/usr/share/sdcc/scripts
        install -o root -g root -m 755  support/scripts/inc2h.pl       debian/tmp/usr/share/sdcc/scripts
        install -o root -g root -m 755  support/scripts/keil2sdcc.pl   debian/tmp/usr/share/sdcc/scripts
 
@@ -117,6 +116,17 @@ install-stamp: build
                $(CURDIR)/debian/cc1111/usr/share/lintian/overrides/cc1111
        # Install examples
        cp -a device/examples $(CURDIR)/debian/cc1111/usr/share/doc/cc1111
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/doc/cc1111/examples/ds400
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/doc/cc1111/examples/ds390
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/doc/cc1111/examples/xa51
+       # clean up things cc1111 doesn't need
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/pic
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/pic16
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/ds400
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/hc08
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/z80
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/ds390
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/gbz80
        touch $@
 
 # Must not depend on anything. This is to be called by binary-arch/binary-indep