more work on lintian issues like hardening and arch/indep targets
authorBdale Garbee <bdale@gag.com>
Mon, 11 Jun 2012 02:41:25 +0000 (20:41 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 11 Jun 2012 02:41:25 +0000 (20:41 -0600)
debian/rules

index 34ba6db1862a089a73366f6f018ee3ea5e08a21a..f0a0ea22bc31573933e369562f5e3cd4140bdac7 100755 (executable)
@@ -10,6 +10,11 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 export HOME=$(CURDIR)/build
 
+CFLAGS = `dpkg-buildflags --get CFLAGS`
+CFLAGS += -Wall -Wno-comment
+LDFLAGS = `dpkg-buildflags --get LDFLAGS`
+CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
+
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g -O0
        export STRIP=true
@@ -78,8 +83,10 @@ configure-stamp: $(QUILT_STAMPFN)
                --disable-z80-port 
        touch $@
 
-build: build-stamp
-build-stamp:  configure-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+build-stamp: configure-stamp
        dh_testdir
        $(MAKE)
        cd doc && lyx -e ps sdccman.lyx
@@ -157,4 +164,4 @@ binary-arch: install
        $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
 
 binary: binary-arch binary-indep
-.PHONY: build clean binary-indep binary-arch binary install install-arch install-indep
+.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install install-arch install-indep