patches from Kamal Mostafa <kamal@whence.com> for rules and gcc 4.6.3 issues
authorBdale Garbee <bdale@gag.com>
Fri, 5 Oct 2012 00:42:11 +0000 (18:42 -0600)
committerBdale Garbee <bdale@gag.com>
Fri, 5 Oct 2012 00:42:11 +0000 (18:42 -0600)
debian/changelog
debian/patches/05_fix_format_not_a_string_literal [new file with mode: 0644]
debian/patches/series
debian/rules

index 5c67a62f87e9baf84eac6849b4d3e5ae8877f39d..7eb24ac9d1ee81a2a15f1289fdaebf7e2ae2dfe6 100644 (file)
@@ -1,3 +1,12 @@
+cc1111 (2.9.0-3) unstable; urgency=low
+
+  [ Kamal Mostafa ]
+  * fix build on older platforms:
+    - debian/rules now uses $(shell) instead of ``
+  * patch to fix format-not-a-string-literal errors with gcc 4.6.3
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 04 Oct 2012 18:41:03 -0600
+
 cc1111 (2.9.0-2) unstable; urgency=low
 
   * fix details identified by ftp-master during initial NEW processing
diff --git a/debian/patches/05_fix_format_not_a_string_literal b/debian/patches/05_fix_format_not_a_string_literal
new file mode 100644 (file)
index 0000000..79ff308
--- /dev/null
@@ -0,0 +1,28 @@
+Author: Kamal Mostafa <kamal@whence.com>
+Description: Fix instances of "format not a string literal"
+
+Fix these, which are a warning on some gcc versions but an error on gcc 4.6.3:
+
+libcpp/macro.c:1660:15: error: format not a string literal and no format arguments [-Werror=format-security]
+libcpp/macro.c:1673:15: error: format not a string literal and no format arguments [-Werror=format-security]
+
+--- cc1111-2.9.0.orig/support/cpp/libcpp/macro.c
++++ cc1111-2.9.0/support/cpp/libcpp/macro.c
+@@ -1657,7 +1657,7 @@ create_iso_definition (cpp_reader *pfile
+              function-like macros, but not at the end.  */
+           if (following_paste_op)
+             {
+-              cpp_error (pfile, CPP_DL_ERROR, paste_op_error_msg);
++              cpp_error (pfile, CPP_DL_ERROR, "%s", paste_op_error_msg);
+               return false;
+             }
+           break;
+@@ -1670,7 +1670,7 @@ create_iso_definition (cpp_reader *pfile
+              function-like macros, but not at the beginning.  */
+           if (macro->count == 1)
+             {
+-              cpp_error (pfile, CPP_DL_ERROR, paste_op_error_msg);
++              cpp_error (pfile, CPP_DL_ERROR, "%s", paste_op_error_msg);
+               return false;
+             }
index 573db36cfdadbc2374a850c61326d48ed21ba48a..55137df2ed7b13a1c30c7fbde81ba9a1bc3ab83c 100644 (file)
@@ -2,3 +2,4 @@
 02_result_type_gptr
 03_fix_cmdlex
 04_libtool_fix
+05_fix_format_not_a_string_literal
index 01210e1b7493e00c60a668abb1464af9b4fd97f5..171c82a56672df9e6e2f7811635800378dfdc144 100755 (executable)
@@ -9,10 +9,10 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 export HOME=$(CURDIR)/build
 
-CFLAGS = `dpkg-buildflags --get CFLAGS`
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
 CFLAGS += -Wall -Wno-comment
-LDFLAGS = `dpkg-buildflags --get LDFLAGS`
-CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
 
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g -O0