lose more stuff we don't actually need from the package
[debian/cc1111] / debian / rules
index 9913097f7f809bfc828f9c4cc19f025a939ed91e..34ba6db1862a089a73366f6f018ee3ea5e08a21a 100755 (executable)
@@ -97,7 +97,6 @@ install-stamp: build
        mv debian/tmp/usr/share/doc/sdcc/* debian/tmp/usr/share/doc/cc1111/
        # Add some scripts
        mkdir -p debian/tmp/usr/share/sdcc/scripts
-       install -o root -g root -m 755  support/scripts/inc2h-pic16.pl debian/tmp/usr/share/sdcc/scripts
        install -o root -g root -m 755  support/scripts/inc2h.pl       debian/tmp/usr/share/sdcc/scripts
        install -o root -g root -m 755  support/scripts/keil2sdcc.pl   debian/tmp/usr/share/sdcc/scripts
 
@@ -117,6 +116,17 @@ install-stamp: build
                $(CURDIR)/debian/cc1111/usr/share/lintian/overrides/cc1111
        # Install examples
        cp -a device/examples $(CURDIR)/debian/cc1111/usr/share/doc/cc1111
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/doc/cc1111/examples/ds400
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/doc/cc1111/examples/ds390
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/doc/cc1111/examples/xa51
+       # clean up things cc1111 doesn't need
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/pic
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/pic16
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/ds400
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/hc08
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/z80
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/ds390
+       rm -rf $(CURDIR)/debian/cc1111/usr/share/sdcc/lib/src/gbz80
        touch $@
 
 # Must not depend on anything. This is to be called by binary-arch/binary-indep