clean up approach to handling config files
authorBdale Garbee <bdale@gag.com>
Mon, 26 Dec 2011 07:14:27 +0000 (00:14 -0700)
committerBdale Garbee <bdale@gag.com>
Mon, 26 Dec 2011 07:14:27 +0000 (00:14 -0700)
debian/rules

index 236bb6ef539eb03e0e53a3f922a8f5126573f2de..96b231761ae68f2d88fd52f51207b6438339612a 100755 (executable)
@@ -22,6 +22,8 @@ endif
 
 config.status: configure
        dh_testdir
+       cp -f /usr/share/misc/config.sub config.sub
+       cp -f /usr/share/misc/config.guess config.guess
        ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
@@ -45,13 +47,6 @@ clean:
        -$(MAKE) distclean
        rm -rf tmp
 
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
-       cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
-       cp -f /usr/share/misc/config.guess config.guess
-endif
-       
        dh_clean
 
 install: