Align loader to 32-bit boundary
[fw/stlink] / Makefile.am
index a315dd726419d2e3ac9daea21c6f093720b66dff..9afbc0f0b0b06c4a18a8f391e22ba3b71138a33c 100644 (file)
@@ -1,12 +1,20 @@
 # Makefile.am -- Process this file with automake to produce Makefile.in
 
+SUBDIRS = . $(MAYBE_GUI)
+
 AUTOMAKE_OPTIONS = subdir-objects
 
-bin_PROGRAMS = st-flash st-util
+if MINGW
+bin_PROGRAMS = st-flash st-util st-info
+else
+bin_PROGRAMS = st-flash st-util st-term st-info
+endif
 
 noinst_LIBRARIES      = libstlink.a
 
 st_flash_SOURCES = flash/main.c
+st_term_SOURCES = src/st-term.c
+st_info_SOURCES = src/st-info.c
 st_util_SOURCES = gdbserver/gdb-remote.c gdbserver/gdb-remote.h gdbserver/gdb-server.c mingw/mingw.c mingw/mingw.h
 
 CFILES = \
@@ -15,6 +23,10 @@ CFILES = \
        src/stlink-sg.c \
        src/uglylogging.c
 
+if !MINGW
+CFILES += src/st-term.c
+endif
+
 HFILES = \
        src/stlink-common.h \
        src/stlink-usb.h \
@@ -33,5 +45,10 @@ st_flash_CPPFLAGS    = -std=gnu99 -Wall -Wextra -O2 -I$(top_srcdir)/src -I$(top_src
 st_util_LDADD  =       libstlink.a
 st_util_CPPFLAGS       = -std=gnu99 -Wall -Wextra -O2 -I$(top_srcdir)/src -I$(top_srcdir)/mingw
 
-EXTRA_DIST = autogen.sh
+st_term_LDADD   =       libstlink.a
+st_term_CPPFLAGS        = -std=gnu99 -Wall -Wextra -O2 -I$(top_srcdir)/src -I$(top_srcdir)/mingw
 
+st_info_LDADD   =       libstlink.a
+st_info_CPPFLAGS        = -std=gnu99 -Wall -Wextra -O2 -I$(top_srcdir)/src -I$(top_srcdir)/mingw
+
+EXTRA_DIST = autogen.sh