Align loader to 32-bit boundary
[fw/stlink] / Makefile.am
index 9c99297ecc80f324ef5ba2d655d1ab138edd3010..9afbc0f0b0b06c4a18a8f391e22ba3b71138a33c 100644 (file)
@@ -1,21 +1,31 @@
 # Makefile.am -- Process this file with automake to produce Makefile.in
 
+SUBDIRS = . $(MAYBE_GUI)
+
 AUTOMAKE_OPTIONS = subdir-objects
 
-bin_PROGRAMS = st-flash st-util st-term
+if MINGW
+bin_PROGRAMS = st-flash st-util st-info
+else
+bin_PROGRAMS = st-flash st-util st-term st-info
+endif
 
 noinst_LIBRARIES      = libstlink.a
 
 st_flash_SOURCES = flash/main.c
 st_term_SOURCES = src/st-term.c
+st_info_SOURCES = src/st-info.c
 st_util_SOURCES = gdbserver/gdb-remote.c gdbserver/gdb-remote.h gdbserver/gdb-server.c mingw/mingw.c mingw/mingw.h
 
 CFILES = \
        src/stlink-common.c \
        src/stlink-usb.c \
        src/stlink-sg.c \
-       src/uglylogging.c \
-        src/st-term.c
+       src/uglylogging.c
+
+if !MINGW
+CFILES += src/st-term.c
+endif
 
 HFILES = \
        src/stlink-common.h \
@@ -38,6 +48,7 @@ st_util_CPPFLAGS      = -std=gnu99 -Wall -Wextra -O2 -I$(top_srcdir)/src -I$(top_srcd
 st_term_LDADD   =       libstlink.a
 st_term_CPPFLAGS        = -std=gnu99 -Wall -Wextra -O2 -I$(top_srcdir)/src -I$(top_srcdir)/mingw
 
+st_info_LDADD   =       libstlink.a
+st_info_CPPFLAGS        = -std=gnu99 -Wall -Wextra -O2 -I$(top_srcdir)/src -I$(top_srcdir)/mingw
 
 EXTRA_DIST = autogen.sh
-