Enabled VPATH feature: changed nearly all Makefiles (149 files).
[fw/sdcc] / support / regression / ports / z80 / spec.mk
index 2a568d9d3d8767e24ca8ce18bae2294e24fe99d3..3c0aebd52858e87fa67ee56b3a6abed99d69b060 100644 (file)
@@ -3,42 +3,40 @@
 
 RRZ80 = $(SDCC_EXTRA_DIR)/emu/rrz80/rrz80
 
-SDCCFLAGS +=-mz80 --nostdinc --less-pedantic --profile -DREENTRANT=
+SDCCFLAGS +=-mz80 --nostdinc --less-pedantic --profile -DREENTRANT= -I$(top_srcdir)
 LINKFLAGS = --nostdlib
 LINKFLAGS += z80.lib
-LIBDIR = $(SDCC_DIR)/device/lib/build/z80
+LIBDIR = $(top_builddir)device/lib/build/z80
 
 EXEEXT = .bin
 
 # Needs parts of gbdk-lib, namely the internal mul/div/mod functions.
-EXTRAS = ports/$(PORT)/testfwk$(OBJEXT) ports/$(PORT)/support$(OBJEXT)
+EXTRAS = $(PORT_CASES_DIR)/testfwk$(OBJEXT) $(PORT_CASES_DIR)/support$(OBJEXT)
 
 # Rule to generate a Emulator .bin file from the .ihx linker output.
 %$(EXEEXT): %.ihx
-       $(SDCC_DIR)/bin/makebin -s 32768 < $< > $@
+       $(top_builddir)bin/makebin -s 32768 < $< > $@
 
 # Rule to link into .ihx
 %.ihx: %.c $(EXTRAS)
        $(SDCC) $(SDCCFLAGS) $(LINKFLAGS) -L $(LIBDIR) $(EXTRAS) $< -o $@
 
-%$(OBJEXT): %.asm
-       $(SDCC_DIR)/bin/as-z80 -plosgff $@ $<
+$(PORT_CASES_DIR)/%$(OBJEXT): $(PORTS_DIR)/$(PORT)/%.asm
+       $(top_builddir)bin/as-z80 -plosgff $@ $<
 
 %$(OBJEXT): %.s
-       $(SDCC_DIR)/bin/as-z80 -plosgff $@ $<
+       $(top_builddir)bin/as-z80 -plosgff $@ $<
 
 %$(OBJEXT): %.c
        $(SDCC) $(SDCCFLAGS) -c $< -o $@
 
-ports/$(PORT)/%$(OBJEXT): fwk/lib/%.c
+$(PORT_CASES_DIR)/%$(OBJEXT): fwk/lib/%.c
        $(SDCC) $(SDCCFLAGS) -c $< -o $@
 
 # PENDING: Path to sdcc-extra
 %.out: %$(EXEEXT)
-       mkdir -p `dirname $@`
+       mkdir -p $(dir $@)
        $(RRZ80) --maxruntime=3 --mapfile=$(<:.bin=.sym) $< > $@
        -grep -n FAIL $@ /dev/null || true
 
 _clean:
-       rm -f ports/$(PORT)/testfwk.asm ports/$(PORT)/*.lst ports/$(PORT)/*.o ports/$(PORT)/*.sym
-