* Makefile.in, configure.in, configure,
[fw/sdcc] / support / regression / ports / mcs51-xstack-auto / spec.mk
index ae82b657cd6b4bcd94a4ff42072fe75906a772e0..99d9c3febbe50b0afb1a31d98287a9f134ad5026 100644 (file)
@@ -1,8 +1,16 @@
-# Port specification for the mcs51 port running with uCsim
+# Regression test specification for the mcs51-xstack-auto target running with uCsim
 #
-# model small stack-auto
+# model small xstack-auto
 
-include $(PORTS_DIR)/mcs51-stack-auto/spec.mk
+LIBSDCCFLAGS+= --stack-auto --xstack --std-c99 -DUSE_FLOATS=1
+SDCCFLAGS   += --stack-auto --xstack --std-sdcc99
 
-LIBSDCCFLAGS+= --xstack
-SDCCFLAGS   +=$(LIBSDCCFLAGS)
+include $(PORTS_DIR)/mcs51-common/spec.mk
+
+LIBDIR      = $(top_builddir)/device/lib/build/small-xstack-auto
+
+MAKE_LIBRARY = lib-files
+
+.PHONY: lib-files
+lib-files:
+       make -C $(top_builddir)/device/lib model-mcs51-xstack-auto MODELS=small