Some hc08 related updates that I missed earlier
[fw/sdcc] / support / regression / ports / hc08 / spec.mk
index 8a3be0a42d911c5d5184ad2ebf3196a7cfa1e5c3..b8cec52f3759fc3bd84f6412c8e11f429b782368 100644 (file)
@@ -1,8 +1,8 @@
-# Port specification for the xxxx port running with uCsim
-#
-
 # path to uCsim
-UCHC08 = $(SDCC_DIR)/bin/shc08
+UCHC08A = $(SDCC_DIR)/sim/ucsim/hc08.src/shc08
+UCHC08B = $(SDCC_DIR)/bin/shc08
+
+UCHC08 = $(shell if [ -f $(UCHC08A) ]; then echo $(UCHC08A); else echo $(UCHC08B); fi)
 
 SDCCFLAGS +=-mhc08 --less-pedantic --out-fmt-ihx -DREENTRANT=
 #SDCCFLAGS +=--less-pedantic -DREENTRANT=reentrant