* configure.in: added missing mcs51 in status output
[fw/sdcc] / support / cpp2 / configure.in
index 65a6d93ffd9d550ff8429a890b04e552d85fb2dc..8f47d09dfd4136cf46b598d77e84b033e9a305c7 100644 (file)
@@ -21,8 +21,8 @@
 #02111-1307, USA.
 
 # Initialization and defaults
-AC_PREREQ(2.13)
-AC_INIT(cppmain.c)
+AC_PREREQ(2.60)
+AC_INIT(sdcpp.c)
 AC_CONFIG_HEADER(auto-host.h:config.in)
 
 remove=rm
@@ -167,6 +167,13 @@ else
 fi
 
 # Find some useful tools
+AC_PROG_AWK
+# We need awk to run opts.sh (to create options.c and options.h).
+# Bail out if it's missing.
+case ${AWK} in
+  "") AC_MSG_ERROR([can't build without awk, bailing out]) ;;
+esac
+
 gcc_AC_PROG_LN
 gcc_AC_PROG_LN_S
 AC_PROG_RANLIB
@@ -200,7 +207,7 @@ AC_C_STRINGIZE
 dnl Disabled until we have a complete test for buggy enum bitfields.
 dnl gcc_AC_C_ENUM_BF_UNSIGNED
 
-AC_CHECK_FUNCS(clock strchr strrchr lstat)
+AC_CHECK_FUNCS(clock strsignal strchr strrchr lstat)
 
 AC_CHECK_TYPE(ssize_t, int)
 
@@ -210,7 +217,7 @@ AC_FUNC_MMAP_FILE
 # We will need to find libiberty.h and ansidecl.h
 saved_CFLAGS="$CFLAGS"
 CFLAGS="$CFLAGS -I${srcdir} -I${srcdir}/../include"
-gcc_AC_CHECK_DECLS(getenv abort errno \
+gcc_AC_CHECK_DECLS(getenv abort strsignal errno \
        malloc realloc calloc free clock, , ,[
 #include "ansidecl.h"
 #include "system.h"])