New target "hc08" for the Motorola 68hc08 family of micros
[fw/sdcc] / sim / ucsim / configure.in
index 4ac594f2ec6104754ead43f6492dca71a24861eb..9f25ae00e102ba942a50faec9914ab0b65f0963c 100644 (file)
@@ -58,6 +58,12 @@ if test $enable_z80 != "no"; then
     enable_z80="yes"
 fi,
 enable_z80="no")
+AC_ARG_ENABLE(hc08,
+[  --enable-hc08            compile simulator for hc08],
+if test $enable_hc08 != "no"; then
+    enable_hc08="yes"
+fi,
+enable_hc08="yes")
 AC_ARG_ENABLE(xa,
 [  --enable-xa             compile simulator for XA],
 if test $enable_xa != "no"; then
@@ -75,6 +81,7 @@ AC_SUBST(enable_dlso)
 AC_SUBST(enable_51)
 AC_SUBST(enable_avr)
 AC_SUBST(enable_z80)
+AC_SUBST(enable_hc08)
 AC_SUBST(enable_xa)
 AC_SUBST(enable_serio)
 
@@ -470,6 +477,7 @@ cmd.src/Makefile
 s51.src/Makefile
 avr.src/Makefile
 z80.src/Makefile
+hc08.src/Makefile
 xa.src/Makefile
 gui.src/Makefile
 gui.src/serio.src/Makefile