* as/z80/z80mch.c: fixed bug #1704376: missing as-z80 errors
[fw/sdcc] / sdcc.spec
index 862be2a9e4aee90f6b5caad7342b5b704d032dca..aa5ec7ef87efa858b3a75b27ed18c2b7be9044dd 100644 (file)
--- a/sdcc.spec
+++ b/sdcc.spec
@@ -4,15 +4,15 @@
 
 Name:          sdcc
 Requires:      /bin/sh
-License:       GPL, LGPL
+License:       GPL
 Group:         Applications/Engineering
-Provides:      sdcc
 Summary:       Small Device C Compiler
-Version:       2.3.7
-Release:       4
-Source:        %{name}-%{version}.tar.bz2
+Requires:      sdcc-common
+Version:       2.8.0
+Release:       2
+Source:        %{name}-src-%{version}.tar.gz
 URL:           http://sdcc.sourceforge.net/
-Packager:      Bernhard Held <bernhard@bernhardheld.de>
+Packager:      Bernhard Held <bernhard AT bernhardheld.de>
 BuildRoot:     %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -21,32 +21,72 @@ The package includes the compiler, assemblers and linkers, a device
 simulator and a core library. The processors supported (to a varying
 degree) include the 8051, ds390, z80, hc08, and PIC.
 
+%package common
+License:       GPL, LGPL
+Group:         Application/Engineering
+Summary:       Libraries and Header Files for the SDCC C compiler
+Requires:      sdcc
+
+%description common
+SDCC is a C compiler for 8051 class and similar microcontrollers.
+The package includes the compiler, assemblers and linkers, a device
+simulator and a core library. The processors supported (to a varying
+degree) include the 8051, ds390, z80, hc08, and PIC.
+
+%package doc
+License:       GPL
+Group:         Applications/Engineering
+Summary:       Documentation for the SDCC C compiler
+
+%description doc
+SDCC is a C compiler for 8051 class and similar microcontrollers.
+The package includes the compiler, assemblers and linkers, a device
+simulator and a core library. The processors supported (to a varying
+degree) include the 8051, ds390, z80, hc08, and PIC.
+
 %prep
 %setup -n sdcc
 
 %build
-./configure CFLAGS="$RPM_OPT_FLAGS" --prefix=/usr docdir=$RPM_BUILD_ROOT/%{_defaultdocdir}/%{name}
+./configure CFLAGS="$RPM_OPT_FLAGS" --prefix=/usr --enable-doc docdir=$RPM_BUILD_ROOT/%{_defaultdocdir}/%{name}
 make
 cd doc
 make
 cd ..
 
 %install
-rm -rf $RPM_BUILD_ROOT/usr
+rm -rf $RPM_BUILD_ROOT
 make prefix=$RPM_BUILD_ROOT/usr install
 cd doc
 make install
 cd ..
 
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 %files
 %defattr(-,root,root)
 /usr/bin
+
+%files common
+%defattr(-,root,root)
 /usr/share/sdcc/include
 /usr/share/sdcc/lib
+
+%files doc
+%defattr(-,root,root)
 %doc %{_defaultdocdir}
 
 %changelog
-* Sun Jan 04 2004 - bernhard@bernhardheld.de
+* Sun Dec 26 2006 - bernhard AT bernhardheld.de
+- version updated
+* Sun Sep 03 2006 - Christer Weinigel
+- fixed build of doc
+* Tue Mar 09 2004 - bernhard AT bernhardheld.de
+- split into two packages
+* Wed Feb 26 2004 - bernhard AT bernhardheld.de
+- version updated
+* Sun Jan 04 2004 - bernhard AT bernhardheld.de
 - updated
-* Sat Apr 27 2002 - steve@icarus.com
+* Sat Apr 27 2002 - steve AT icarus.com
 - first version from Stephen Williams