* as/z80/z80mch.c: fixed bug #1704376: missing as-z80 errors
[fw/sdcc] / sdcc.spec
index 1db35ce9acf4cab42e25ae6bf93511833c5f9ddb..aa5ec7ef87efa858b3a75b27ed18c2b7be9044dd 100644 (file)
--- a/sdcc.spec
+++ b/sdcc.spec
@@ -1,43 +1,92 @@
-Summary: Small Device C Compiler
-Name: sdcc
-Version: 2.2.2
-Release: 0.20010225
-Copyright: GPL
-Group: Applications/Engineering
-Source: sdcc-2.2.2.tar.gz
-URL: http://sdcc.sourceforge.net/
-Packager: Stephen Williams <steve@icarus.com>
-
-BuildRoot: /tmp/sdcc
+#
+# spec file for package sdcc
+#
+
+Name:          sdcc
+Requires:      /bin/sh
+License:       GPL
+Group:         Applications/Engineering
+Summary:       Small Device C Compiler
+Requires:      sdcc-common
+Version:       2.8.0
+Release:       2
+Source:        %{name}-src-%{version}.tar.gz
+URL:           http://sdcc.sourceforge.net/
+Packager:      Bernhard Held <bernhard AT bernhardheld.de>
+BuildRoot:     %{_tmppath}/%{name}-%{version}-build
 
 %description
-SDC is a C compiler for 8051 class and similar microcontrollers.
-The packge includes the compiler, assemblers and linkers, a device
+SDCC is a C compiler for 8051 class and similar microcontrollers.
+The package includes the compiler, assemblers and linkers, a device
+simulator and a core library. The processors supported (to a varying
+degree) include the 8051, ds390, z80, hc08, and PIC.
+
+%package common
+License:       GPL, LGPL
+Group:         Application/Engineering
+Summary:       Libraries and Header Files for the SDCC C compiler
+Requires:      sdcc
+
+%description common
+SDCC is a C compiler for 8051 class and similar microcontrollers.
+The package includes the compiler, assemblers and linkers, a device
 simulator and a core library. The processors supported (to a varying
-degree) include the 8051, avr and z80.
+degree) include the 8051, ds390, z80, hc08, and PIC.
+
+%package doc
+License:       GPL
+Group:         Applications/Engineering
+Summary:       Documentation for the SDCC C compiler
+
+%description doc
+SDCC is a C compiler for 8051 class and similar microcontrollers.
+The package includes the compiler, assemblers and linkers, a device
+simulator and a core library. The processors supported (to a varying
+degree) include the 8051, ds390, z80, hc08, and PIC.
 
 %prep
-%setup -n sdcc-2.2.2
+%setup -n sdcc
 
 %build
-./configure --prefix=/usr/local
-make all
+./configure CFLAGS="$RPM_OPT_FLAGS" --prefix=/usr --enable-doc docdir=$RPM_BUILD_ROOT/%{_defaultdocdir}/%{name}
+make
+cd doc
+make
+cd ..
 
 %install
-make prefix=$RPM_BUILD_ROOT/usr/local  install
+rm -rf $RPM_BUILD_ROOT
+make prefix=$RPM_BUILD_ROOT/usr install
+cd doc
+make install
+cd ..
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %files
+%defattr(-,root,root)
+/usr/bin
 
-%attr(-,root,root) /usr/local/bin/sdcc
-%attr(-,root,root) /usr/local/bin/sdcpp
-%attr(-,root,root) /usr/local/bin/asx8051
-%attr(-,root,root) /usr/local/bin/aslink
-%attr(-,root,root) /usr/local/bin/packihx
-%attr(-,root,root) /usr/local/bin/sdcdb
-%attr(-,root,root) /usr/local/share/sdcc
+%files common
+%defattr(-,root,root)
+/usr/share/sdcc/include
+/usr/share/sdcc/lib
 
-%attr(-,root,root) /usr/local/bin/s51
-%attr(-,root,root) /usr/local/bin/savr
-%attr(-,root,root) /usr/local/bin/sz80
+%files doc
+%defattr(-,root,root)
+%doc %{_defaultdocdir}
 
-%attr(-,root,root) %doc /usr/local/doc/ucsim
+%changelog
+* Sun Dec 26 2006 - bernhard AT bernhardheld.de
+- version updated
+* Sun Sep 03 2006 - Christer Weinigel
+- fixed build of doc
+* Tue Mar 09 2004 - bernhard AT bernhardheld.de
+- split into two packages
+* Wed Feb 26 2004 - bernhard AT bernhardheld.de
+- version updated
+* Sun Jan 04 2004 - bernhard AT bernhardheld.de
+- updated
+* Sat Apr 27 2002 - steve AT icarus.com
+- first version from Stephen Williams