Enabled VPATH feature: changed nearly all Makefiles (149 files).
[fw/sdcc] / device / lib / pic16 / configure.in
index ac9b28eb276356e08643cc6c894c114f1f326ce6..d08d9e37b403b67112c4e1c8206862500b1d9be6 100644 (file)
@@ -42,7 +42,33 @@ AC_PROG_MAKE_SET
 
 # Checks for library functions.
 
-$CP pics.all pics.build
+$CP "$srcdir"/pics.all pics.build
 
-AC_CONFIG_FILES([Makefile.common])
+AC_CONFIG_FILES([Makefile
+                 Makefile.common
+                 debug/Makefile
+                 debug/gstack/Makefile
+                 libc/Makefile
+                 libc/ctype/Makefile
+                 libc/delay/Makefile
+                 libc/stdio/Makefile
+                 libc/stdlib/Makefile
+                 libc/string/Makefile
+                 libc/utils/Makefile
+                 libdev/Makefile
+                 libio/Makefile
+                 libio/adc/Makefile
+                 libio/i2c/Makefile
+                 libio/usart/Makefile
+                 libm/Makefile
+                 libsdcc/Makefile
+                 libsdcc/char/Makefile
+                 libsdcc/fixed16x16/Makefile
+                 libsdcc/float/Makefile
+                 libsdcc/gptr/Makefile
+                 libsdcc/int/Makefile
+                 libsdcc/long/Makefile
+                 libsdcc/lregs/Makefile
+                 startup/Makefile
+                 ])
 AC_OUTPUT