Use 'ao-dbg' instead of 's51' to communicate with TeleMetrum
[fw/sdcc] / sdcc.spec
1 #
2 # spec file for package sdcc
3 #
4
5 Name:          sdcc
6 Requires:      /bin/sh
7 License:       GPL
8 Group:         Applications/Engineering
9 Summary:       Small Device C Compiler
10 Requires:      sdcc-common
11 Version:       2.9.0
12 Release:       2
13 Source:        %{name}-src-%{version}.tar.gz
14 URL:           http://sdcc.sourceforge.net/
15 Packager:      Bernhard Held <bernhard AT bernhardheld.de>
16 BuildRoot:     %{_tmppath}/%{name}-%{version}-build
17
18 %description
19 SDCC is a C compiler for 8051 class and similar microcontrollers.
20 The package includes the compiler, assemblers and linkers, a device
21 simulator and a core library. The processors supported (to a varying
22 degree) include the 8051, ds390, z80, hc08, and PIC.
23
24 %package common
25 License:       GPL, LGPL
26 Group:         Application/Engineering
27 Summary:       Libraries and Header Files for the SDCC C compiler
28 Requires:      sdcc
29
30 %description common
31 SDCC is a C compiler for 8051 class and similar microcontrollers.
32 The package includes the compiler, assemblers and linkers, a device
33 simulator and a core library. The processors supported (to a varying
34 degree) include the 8051, ds390, z80, hc08, and PIC.
35
36 %package doc
37 License:       GPL
38 Group:         Applications/Engineering
39 Summary:       Documentation for the SDCC C compiler
40
41 %description doc
42 SDCC is a C compiler for 8051 class and similar microcontrollers.
43 The package includes the compiler, assemblers and linkers, a device
44 simulator and a core library. The processors supported (to a varying
45 degree) include the 8051, ds390, z80, hc08, and PIC.
46
47 %prep
48 %setup -n sdcc
49
50 %build
51 ./configure CFLAGS="$RPM_OPT_FLAGS" --prefix=/usr --enable-doc docdir=$RPM_BUILD_ROOT/%{_defaultdocdir}/%{name}
52 make
53 cd doc
54 make
55 cd ..
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 make prefix=$RPM_BUILD_ROOT/usr install
60 cd doc
61 make install
62 cd ..
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(-,root,root)
69 /usr/bin
70
71 %files common
72 %defattr(-,root,root)
73 /usr/share/sdcc/include
74 /usr/share/sdcc/lib
75
76 %files doc
77 %defattr(-,root,root)
78 %doc %{_defaultdocdir}
79
80 %changelog
81 * Sun Dec 26 2006 - bernhard AT bernhardheld.de
82 - version updated
83 * Sun Sep 03 2006 - Christer Weinigel
84 - fixed build of doc
85 * Tue Mar 09 2004 - bernhard AT bernhardheld.de
86 - split into two packages
87 * Wed Feb 26 2004 - bernhard AT bernhardheld.de
88 - version updated
89 * Sun Jan 04 2004 - bernhard AT bernhardheld.de
90 - updated
91 * Sat Apr 27 2002 - steve AT icarus.com
92 - first version from Stephen Williams