doc: Update for 1.9.7
[fw/altos] / doc / Makefile.am
index b5839beaee98474be055578df88356a9c799297a..560c868f2c367580b0941236115549c586563504 100644 (file)
@@ -17,6 +17,14 @@ FAKETIME=TZ=UTC faketime -f '$(RELEASE_DATE) 00:00:00 i0'
 endif
 
 RELNOTES_INC=\
+       release-notes-1.9.7.inc \
+       release-notes-1.9.6.inc \
+       release-notes-1.9.5.inc \
+       release-notes-1.9.4.inc \
+       release-notes-1.9.3.inc \
+       release-notes-1.9.2.inc \
+       release-notes-1.9.1.inc \
+       release-notes-1.9.inc \
        release-notes-1.8.7.inc \
        release-notes-1.8.6.inc \
        release-notes-1.8.5.inc \
@@ -64,6 +72,7 @@ IMAGES=\
        easymega-v1.0-top.jpg \
        easymini.svg \
        easymini-top.jpg \
+       easytimer.jpg \
        fire-igniter.png \
        graph-configure.png \
        graph-map.png \
@@ -139,6 +148,7 @@ INC_FILES=\
        easymini-device.inc \
        telemega.inc \
        easymega.inc \
+       easytimer.inc \
        installation.inc \
        using-am-products.inc \
        updating-firmware.inc \
@@ -154,6 +164,31 @@ INC_FILES=\
 
 ADOC_FILES=$(TXT_FILES:.txt=.adoc) $(INC_FILES:.inc=.adoc)
 
+MOTORTEST_TXT_FILES=motortest.txt
+
+MOTORTEST_INC_FILES=\
+       motortest-configuration.inc \
+       motortest-installation.inc \
+       motortest-intro.inc \
+       motortest-operation.inc
+
+MOTORTEST_ADOC_FILES=$(MOTORTEST_TXT_FILES:.txt=.adoc) $(MOTORTEST_INC_FILES:.inc=.adoc)
+
+TELELAUNCH_TXT_FILES=telelaunch.txt
+
+TELELAUNCH_INC_FILES=\
+       header.inc \
+       telelaunch-acknowledgements.inc \
+       telelaunch-intro.inc \
+       telelaunch-configuration.inc \
+       telelaunch-operation.inc \
+       telelaunch-specs.inc \
+       telelaunch-updating-firmware.inc \
+       telelaunch-cables.inc \
+       telelaunch-troubleshooting.inc 
+
+TELELAUNCH_ADOC_FILES=$(TELELAUNCH_TXT_FILES:.txt=.adoc) $(TELELAUNCH_INC_FILES:.inc=.adoc)
+
 TELEGPS_INC_FILES=\
        telegps-dedication.inc \
        telegps-quick-start.inc \
@@ -220,12 +255,14 @@ ONEFILE_HTML_FILES=$(ONEFILE_TXT_FILES:.txt=.html)
 
 AM_HTML=am.html
 
-PUBLISH_HTML=altusmetrum.html micropeak.html telegps.html easymini.html $(ONEFILE_HTML_FILES)
+PUBLISH_HTML=altusmetrum.html micropeak.html telegps.html easymini.html motortest.html telelaunch.html $(ONEFILE_HTML_FILES)
 
 HTML=$(PUBLISH_HTML) $(RELNOTES_HTML)
 
-PDF=altusmetrum.pdf micropeak.pdf telegps.pdf easymini.pdf $(ONEFILE_PDF_FILES) \
+if ASCIIDOCTOR_PDF
+PDF=altusmetrum.pdf micropeak.pdf telegps.pdf easymini.pdf motortest.pdf telelaunch.pdf $(ONEFILE_PDF_FILES) \
        $(OUTLINE_PDF_FILES)
+endif
 
 MAP_DOT_FILES=map-loading.dot
 MAP_SVG_FILES=$(MAP_DOT_FILES:.dot=.svg)
@@ -243,6 +280,13 @@ FONTS=\
        fonts/OpenSans-Semibold.ttf \
        fonts/OpenSans-SemiboldItalic.ttf
 
+ICONS=\
+       images/icons/caution.svg \
+       images/icons/important.svg \
+       images/icons/note.svg \
+       images/icons/tip.svg \
+       images/icons/warning.svg
+
 PDF_CONFIG_FILES=altusmetrum-theme.yml
 HTML_CONFIG_FILES=
 
@@ -252,6 +296,8 @@ DOC=$(HTML) $(PDF) $(IMAGES) $(MAP_SVG_FILES) $(STYLESHEET)
 
 SUFFIXES = .dot .svg .inc .txt .adoc .pdf .html
 
+ATTRIBUTES=--attribute="revdate=$(DOC_DATE)" --attribute="version=$(VERSION)"
+
 .dot.svg:
        dot -Tsvg -o$@ $*.dot
 
@@ -262,22 +308,26 @@ SUFFIXES = .dot .svg .inc .txt .adoc .pdf .html
        sed -e 's/^[    ]*//' -e 's/^\\//' $*.inc > $@
 
 .adoc.html:
-       asciidoctor -b html5 $*.adoc
+       asciidoctor $(ATTRIBUTES) -b html5 $*.adoc
 
 .adoc.pdf:
-       asciidoctor-pdf $*.adoc
+       asciidoctor-pdf $(ATTRIBUTES) $*.adoc
 
 all:   $(HTML) $(PDF)
 
 map-loading.adoc: $(MAP_SVG_FILES)
 
-altusmetrum.pdf altusmetrum.html: altusmetrum-docinfo.xml $(ADOC_FILES) $(IMAGES)
+altusmetrum.pdf altusmetrum.html: $(ADOC_FILES) $(IMAGES)
+
+motortest.pdf motortest.html: $(MOTORTEST_ADOC_FILES) $(IMAGES)
+
+telelaunch.pdf telelaunch.html: $(TELELAUNCH_ADOC_FILES) $(IMAGES)
 
-telegps.html telegps.pdf: telegps-docinfo.xml $(TELEGPS_ADOC_FILES) $(IMAGES)
+telegps.html telegps.pdf: $(TELEGPS_ADOC_FILES) $(IMAGES)
 
-micropeak.pdf micropeak.html: micropeak-docinfo.xml $(MICROPEAK_ADOC_FILES) $(IMAGES)
+micropeak.pdf micropeak.html: $(MICROPEAK_ADOC_FILES) $(IMAGES)
 
-easymini.pdf easymini.html: easymini-docinfo.xml $(EASYMINI_ADOC_FILES) $(IMAGES)
+easymini.pdf easymini.html: $(EASYMINI_ADOC_FILES) $(IMAGES)
 
 telemini-v1-outline.pdf: telemini-v1-outline.txt telemini-v1.svg
 
@@ -287,23 +337,28 @@ install:  all
 
 WEB_ROOT=/home/bdale/web/
 
-publish:       $(PUBLISH_DOC) $(FONTS)
-       cp $(PUBLISH_DOC) $(WEB_ROOT)/altusmetrum/AltOS/doc/
+publish:       $(PUBLISH_DOC) $(FONTS) $(ICONS)
+       cp -a $(PUBLISH_DOC) $(WEB_ROOT)/altusmetrum/AltOS/doc/
        mkdir -p $(WEB_ROOT)/altusmetrum/AltOS/doc/fonts/
        cp $(FONTS) $(WEB_ROOT)/altusmetrum/AltOS/doc/fonts/
+       mkdir -p $(WEB_ROOT)/altusmetrum/AltOS/doc/images/icons/
+       cp $(ICONS) $(WEB_ROOT)/altusmetrum/AltOS/doc/images/icons/
        (cd $(WEB_ROOT)/altusmetrum ; \
         git add $(WEB_ROOT)/altusmetrum/AltOS/doc/* ; \
         git add $(WEB_ROOT)/altusmetrum/AltOS/doc/fonts/* ; \
+        git add $(WEB_ROOT)/altusmetrum/AltOS/doc/images/icons/* ;\
         echo "update docs" | \
-        git commit -F - $(WEB_ROOT)/altusmetrum/AltOS/doc/* $(WEB_ROOT)/altusmetrum/AltOS/doc/fonts/* ; \
+        git commit -F - $(WEB_ROOT)/altusmetrum/AltOS/doc/* $(WEB_ROOT)/altusmetrum/AltOS/doc/fonts/* $(WEB_ROOT)/altusmetrum/AltOS/doc/images/icons ; \
         git push)
 
 publish-keithp:        am.html $(DOC) $(FONTS)
+       ssh keithp.com 'mkdir -p ~keithp/public_html/altos/fonts ~keithp/public_html/altos/images/icons'
        scp -p am.html $(DOC) keithp.com:~keithp/public_html/altos
        scp -p $(FONTS) keithp.com:~keithp/public_html/altos/fonts
+       scp -p $(ICONS) keithp.com:~keithp/public_html/altos/images/icons
 
 clean:
-       rm -f am.html $(HTML) $(PDF) $(ADOC_FILES) $(TELEGPS_ADOC_FILES) $(MICROPEAK_ADOC_FILES)
+       rm -f am.html $(HTML) $(PDF) $(ADOC_FILES) $(TELEGPS_ADOC_FILES) $(MICROPEAK_ADOC_FILES) $(TELELAUNCH_ADOC_FILES) $(MOTORTEST_ADOC_FILES)
 
 distclean: clean
        rm -f $(HTML) $(PDF)