altos/test: Adjust CRC error rate after FEC fix
[fw/altos] / doc / Makefile.am
index 55e574c58e55bc656ce6ff1a5f05a648429169d9..f0d8cfb629d7ede77222bb2aea02b1ed85e6ba1c 100644 (file)
@@ -17,6 +17,17 @@ FAKETIME=TZ=UTC faketime -f '$(RELEASE_DATE) 00:00:00 i0'
 endif
 
 RELNOTES_INC=\
+       release-notes-1.9.17.inc \
+       release-notes-1.9.16.inc \
+       release-notes-1.9.15.inc \
+       release-notes-1.9.14.inc \
+       release-notes-1.9.13.inc \
+       release-notes-1.9.12.inc \
+       release-notes-1.9.11.inc \
+       release-notes-1.9.10.inc \
+       release-notes-1.9.9.inc \
+       release-notes-1.9.8.inc \
+       release-notes-1.9.7.inc \
        release-notes-1.9.6.inc \
        release-notes-1.9.5.inc \
        release-notes-1.9.4.inc \
@@ -133,6 +144,7 @@ COMMON_INC_FILES=\
        config-ui.inc \
        load-maps.inc \
        aprs-operation.inc \
+       pyro-examples.inc \
        handling.inc \
        release-head.inc
 
@@ -151,6 +163,7 @@ INC_FILES=\
        installation.inc \
        using-am-products.inc \
        updating-firmware.inc \
+       frequency-cal.inc \
        altosui.inc \
        altosdroid.inc \
        system-operation.inc \
@@ -163,6 +176,16 @@ INC_FILES=\
 
 ADOC_FILES=$(TXT_FILES:.txt=.adoc) $(INC_FILES:.inc=.adoc)
 
+MOTORTEST_TXT_FILES=motortest.txt
+
+MOTORTEST_INC_FILES=\
+       motortest-configuration.inc \
+       motortest-installation.inc \
+       motortest-intro.inc \
+       motortest-operation.inc
+
+MOTORTEST_ADOC_FILES=$(MOTORTEST_TXT_FILES:.txt=.adoc) $(MOTORTEST_INC_FILES:.inc=.adoc)
+
 TELELAUNCH_TXT_FILES=telelaunch.txt
 
 TELELAUNCH_INC_FILES=\
@@ -244,12 +267,12 @@ ONEFILE_HTML_FILES=$(ONEFILE_TXT_FILES:.txt=.html)
 
 AM_HTML=am.html
 
-PUBLISH_HTML=altusmetrum.html micropeak.html telegps.html easymini.html telelaunch.html $(ONEFILE_HTML_FILES)
+PUBLISH_HTML=altusmetrum.html micropeak.html telegps.html easymini.html motortest.html telelaunch.html $(ONEFILE_HTML_FILES)
 
 HTML=$(PUBLISH_HTML) $(RELNOTES_HTML)
 
 if ASCIIDOCTOR_PDF
-PDF=altusmetrum.pdf micropeak.pdf telegps.pdf easymini.pdf telelaunch.pdf $(ONEFILE_PDF_FILES) \
+PDF=altusmetrum.pdf micropeak.pdf telegps.pdf easymini.pdf motortest.pdf telelaunch.pdf $(ONEFILE_PDF_FILES) \
        $(OUTLINE_PDF_FILES)
 endif
 
@@ -300,7 +323,7 @@ ATTRIBUTES=--attribute="revdate=$(DOC_DATE)" --attribute="version=$(VERSION)"
        asciidoctor $(ATTRIBUTES) -b html5 $*.adoc
 
 .adoc.pdf:
-       asciidoctor-pdf $(ATTRIBUTES) $*.adoc
+       asciidoctor-pdf $(ATTRIBUTES) -a optimize $*.adoc
 
 all:   $(HTML) $(PDF)
 
@@ -308,6 +331,8 @@ map-loading.adoc: $(MAP_SVG_FILES)
 
 altusmetrum.pdf altusmetrum.html: $(ADOC_FILES) $(IMAGES)
 
+motortest.pdf motortest.html: $(MOTORTEST_ADOC_FILES) $(IMAGES)
+
 telelaunch.pdf telelaunch.html: $(TELELAUNCH_ADOC_FILES) $(IMAGES)
 
 telegps.html telegps.pdf: $(TELEGPS_ADOC_FILES) $(IMAGES)
@@ -345,7 +370,7 @@ publish-keithp:     am.html $(DOC) $(FONTS)
        scp -p $(ICONS) keithp.com:~keithp/public_html/altos/images/icons
 
 clean:
-       rm -f am.html $(HTML) $(PDF) $(ADOC_FILES) $(TELEGPS_ADOC_FILES) $(MICROPEAK_ADOC_FILES) $(TELELAUNCH_ADOC_FILES)
+       rm -f am.html $(HTML) $(PDF) $(ADOC_FILES) $(TELEGPS_ADOC_FILES) $(MICROPEAK_ADOC_FILES) $(TELELAUNCH_ADOC_FILES) $(MOTORTEST_ADOC_FILES)
 
 distclean: clean
        rm -f $(HTML) $(PDF)