conditionalize use of git on executability of /usr/bin/git binary
[fw/altos] / debian / rules
index f306f1df6ac1ea78dea8e9e86c43c110f291f03c..f6efe9900a96b5487086e75c0222585086425367 100755 (executable)
@@ -3,16 +3,16 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
-DEB_VERSION := $(shell git describe | tr - +)
+DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; fi | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
        git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
-       git commit ChangeLog debian/changelog \
+       git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
        git tag debian/$(DEB_VERSION)
-       git push --tags master
+       git push --tags origin master
 
 configure: configure-stamp
 configure-stamp: