see if this works
[fw/altos] / debian / rules
index 343cd71a5a457de06052951f25f7fd98ca3b8008..f4e9f840fccd39f337e46cea40bc292e992b2d6e 100755 (executable)
@@ -3,10 +3,10 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
+DEB_VERSION := $(shell -git describe | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       DEB_VERSION := $(shell git describe | tr - +)
        git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
        git commit -n ChangeLog debian/changelog \