automate push of updated and tagged master branch during debian/rules prebuild
[fw/altos] / debian / rules
index 74cc078d889c5d015b0c4a7c43361e07866adda8..f306f1df6ac1ea78dea8e9e86c43c110f291f03c 100755 (executable)
@@ -3,13 +3,16 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
+DEB_VERSION := $(shell git describe | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       dch -v `git describe | tr - +` "build for Debian from git"
+       git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
        git commit ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
+       git tag debian/$(DEB_VERSION)
+       git push --tags master
 
 configure: configure-stamp
 configure-stamp: