oops, forgot to specify the repo to push to
[fw/altos] / debian / rules
index 74cc078d889c5d015b0c4a7c43361e07866adda8..ac594c076242236ce4c40b79a5d9625bd4ac13b0 100755 (executable)
@@ -3,13 +3,16 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
+DEB_VERSION := $(shell git describe | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       dch -v `git describe | tr - +` "build for Debian from git"
+       git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
        git commit ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
+       git tag debian/$(DEB_VERSION)
+       git push --tags origin master
 
 configure: configure-stamp
 configure-stamp: