flush repetitive junk out of debian/changelog, and update the prebuild target
[fw/altos] / debian / rules
index 74cc078d889c5d015b0c4a7c43361e07866adda8..0033fcbedd615d8ca5e2e85daab7a93221917f3a 100755 (executable)
@@ -6,7 +6,7 @@ PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       dch -v `git describe | tr - +` "build for Debian from git"
+       git-dch --release --new-version=`git describe | tr - +`
        git log > ChangeLog
        git commit ChangeLog debian/changelog \
                -m "update changelogs for Debian build"