roll changelog back in prep for another test build
[fw/altos] / debian / changelog
index 0d525f4250baac73130bcf2ae51bed25608dd93a..e786b10f25736a678083229c71bd5eefa8c79ad4 100644 (file)
@@ -1,3 +1,387 @@
+altos (0.9.6.0) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altos: Correct flight log max on Tm to 5k
+  * altosui: Change button to 'Configure Altimeter'
+  * altos: Remove pad_orientation functions from non-accel devices
+  * altos: Add ability to set arbitrary radio frequency
+  * altosui: Add dialogs to configure 'common' frequencies
+  * altosui: Convert from channels to frequencies
+  * Set version to 0.9.5.0
+  * altosui: altimeter is not spelled altimter
+  * altosui: Pull out BlueTooth support
+  * altos: minor type in comment about accel correction
+  * altosui: Must set radio calibration before radio setting
+  * altosui: A few misc cleanups.
+  * altosui: Have single radio_to_frequency function
+  * altosui: Save frequency after setting it in AltosFlightUI
+  * altosui: Show AltosFrequency in scan results
+  * altosui: Remove debugging printfs from AltosSerial
+  * altosui: Flush radio setting to serial device
+  * altosui: Remove unused AltosConfigData from AltosTelemetryReader
+  * altosui: Reading serial from swing thread only bad if remote
+  * altosui: Make set of telemetries to use while scanning configurable
+  * altosui: Add close button to 'fire' dialog
+  * altos: Switch telemini from v0.1 to v1.0
+  * altosui: Don't export product defs from libaltos
+  * altosui: Ensure serial code tracks reply nesting correctly
+  * altosui: Ship TeleMini v1.0 firmware with fat blobs
+  * Altosui: Add flight statistics tab to graph window
+  * altosui: Add a 'Graph Flight' button to the 'landed'  tab
+  * altosui: Prune telemetry file graphs to just the flight
+  * altosui: Plot reasonable data from Tm files
+  * altosui: Move launch-sites.txt file to altusmetrum.org
+  * Bump version to 0.9.6.0
+  * doc: Update altusmetrum.xsl for v1.0 software and TeleMini
+  * doc: Document Ignite Mode and Pad Orientation configuration options
+  * doc: Describe 'stats' tab in Graph UI, 'Graph Flight' button.
+  * doc: Add telemetry docs to debian/linux/mac/windows packages
+  * doc: Add release notes, include them in altusmetrum doc. Shuffle altusmetrum
+  * doc: Add 1.0 release notes.
+  * altos: Pull igniter pins low as soon as possible at boot time
+  * altos: Apply igniter boot pulse-width reduction to telemini
+  * altos: remove monitor disable stubs from altimeter code
+  * ao-tools: ao-list was crashing with more than 3 devices connected
+  * libaltos: Mis-allocated device list in libaltos
+  * altos: shrink text space from ao_config.c
+  * altos: re-write a bit of GPS parsing code to reduce size
+  * altos/altosui: Report log format in the version command
+  * altos: Don't try to use non-basestations for remote eeprom download
+  * altos: Add SPI-based companion board support
+  * altos: Put SPI in slower mode when talking to companion board
+  * altos: Make sure companion task exits cleanly when done
+  * altos: add the 'L' command to show the status of a linked companion board
+  * altos: Check for companion init packet validity was busted
+  * altosui: Add companion support to the flight UI and CSV conversion
+  * altos: Send SPI message at flight state changes
+  * altos: Send serial/flight to companion board
+  * altos: wait 10s for companion to boot
+  * altosui: Clean up eeprom parsing a bit
+  * altosui: Add support for TeleScience eeprom download
+  * altosui: Devices with log-format can also delete flights
+  * altosui: Eliminate inter-chunk flush_input calls
+  * altos: AltosSerial.flush_input shouldn't discard Interrupted exceptions
+  * altos: Correct AO_CONFIG_MINOR from 6 to 7
+  * altos: Reset radio channel to zero when using radio setting
+  * altos: use raw height while waiting for landing
+  * altosui: don't set channel when using radio setting
+  * altosui: Respect storage limits in flight log max config
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 19 Aug 2011 22:47:25 -0600
+
+altos (0.9.4.5) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: Mark empty eeprom records 'invalid', don't generate exception
+  * altosui: Always read whole eeprom block, even at end of flight
+  * altosui: Display eeprom parsing errors to user
+  * Revert "src/ao_gps_skytraq.c: Update logging rate to 10Hz"
+
+  [ Anthony Towns ]
+  * src/ao_cmd: Shave off bytes from doc strings
+
+  [ Keith Packard ]
+  * altos: Oops. Lost a couple of commands when merging the doc patch
+  * altosui: Missed jcommon.jar in the Mac OS install image
+  * Bump published version number to 0.9.1
+  * aoview: remove -s option.
+
+  [ Anthony Towns ]
+  * ao_intflash: Use internal flash for storage
+
+  [ Keith Packard ]
+  * altos: Make serial, usb, beeper and accelerometer optional components
+  * altos/test: Use ao_convert.c instead of hand-coded pres → alt func
+  * altos/test: Add baro-only flight test program
+  * altos: Start with packet slave running. Turn off in pad mode.
+  * altos: Add TeleMini v1.0
+
+  [ Anthony Towns ]
+  * ao_intflash: Avoid overwriting code
+
+  [ Keith Packard ]
+  * altos: Switch LED usage for TeleMini around
+  * altos: Switch pins around for TeleMini
+  * bringup: Add script for telemini
+  * ao-load: Make usb descriptor rewriting optional
+  * altos: oops -- altitude reporting wasn't pausing between signals
+  * altos: Internal flash ops block when running from flash
+
+  [ Anthony Towns ]
+  * ignore new flight test file
+
+  [ Keith Packard ]
+  * altos: Add tiny logging for TeleMini/TeleNano
+  * altos: Add kalman filters for baro-only boards
+  * altos: Tiny logging fixes. Scan at start, stop when land or full.
+  * altos: Add TeleNano support
+
+  [ Bdale Garbee ]
+  * fix up script to work and have reasonable texts
+
+  [ Keith Packard ]
+  * altos: Fix mini/nano default log size to available flash space
+  * altos/test: Add scripts to run lots of flights through the code
+  * altos: Write height values to log for nano/mini
+  * altos: Baro-only boards must not detect launch on accel or speed data
+  * altosui: Add software version to Configure AltosUI dialog
+  * altos: Don't init packet slave on TD. Make slave start optional
+  * altos: Configure packet size from send/recv parameters.
+  * altos: Make telemetry interval more consistent
+  * altos: Split out tiny telemetry from full telemetry
+  * altos: Split telenano main from telemini
+  * altos: The kalman code requires a constant sample rate
+  * altos: New telemetry report format (version 4). Supports tiny telemetry.
+  * altos: Add .sdcdbrc file for teledongle
+  * altos: Add nickle kalman implementation.
+  * altos: Switch telemetrum over to kalman filter
+  * altos: Compute a 'trust' value for the barometer
+  * altos/kalman: Kalman terms can be > 1, use 32-bit fixed point
+  * altos: Clean up some debug stuff in ao_flight.c
+  * altos: Add ao_flight_debug code
+  * altos: Missing parens and some bad arithmetic in the kalman code
+  * altos: Fix up flight code testing
+  * altos: Restore sensible kalman values
+  * altos: Ignore alt error for fast->coast. Allow larger error for baro apogee.
+  * altos: Exit flight test at landing. Allow description in test flight list
+  * Add ao_kalman.h to .gitignore
+  * Add description to test flights
+  * altosui: Add support for telemetry version 4
+  * altosui: Add telemetry format menu and preferences
+  * altosui: Remove a bunch of debug printfs from the eeprom manager code
+  * altosui: Add support for downloading TeleMini/TeleNano flight logs
+  * altosui: Remove extra AltosEepromBlock layer
+  * altosui: swing hide/show methods are deprecated
+  * altosui: Allow TM config connection to be canceled.
+  * altos: Variable log rate in full logging code too
+  * altos: full logging must flush pending data before checking state
+  * altosui: Off-by-one error in telemetry format configuration UI
+  * altosui: Allow radio channel to be configured over the radio link
+  * altosui: Tell serial device which frame to use for timeout dialogs
+  * altosui: Handle serial calls from swing thread
+  * altos: Split up flight code into separate flight/sample/kalman bits
+  * altos: Create custom nano flight code
+  * altosui: Clean up packet link connecting dialog
+  * altosui: Make flight log downloading handle 'Connecting...' dialog
+  * altosui: Make deployment testing handle Connecting... dialog
+  * altosui: Display exception messages from swing thread
+  * altosui: Don't display 0000-00-00 for missing flight log dates
+  * altos: ao_sample_preflight was exiting preflight mode immediately
+  * altos: Run RDF beacon after apogee instead of waiting for landing
+  * altos: Enable logging during nano flights
+  * altosui: Parse and export Max flight log value
+  * altosui: Only plot acceleration when present in data file
+  * altos: Reflect ao_flight split in ao_flight_test dependencies
+  * altos: Baro useful ceiling is MSL, not AGL
+  * altos: Make ao_flight_test show true height but report saturated height
+  * altos: Add initial TeleBT code
+  * altos: Add P2SEL_*_MASK defines to cc1111.h
+  * altos: expose set of available stdio values
+  * altos: Provide for a pre-filter on commands
+  * altos: Allow any stdio to be used with packet forwarding
+  * altos: Remove serial monitor command
+  * altos: Make ao_serial_drain public
+  * altos: Clean up usage of serial port for stdio
+  * altos: Clean up serial initialization
+  * altos: Make cmd echo per-connection instead of global
+  * altos: Clean up BT serial communcations
+  * altosui: Add missing AltosTelemetryMap.java file
+  * altos: Use PIO(6) on BTM to monitor BT connection. Fix BTM init.
+  * altosui: Add TeleBT USB device support
+  * altosui: Add low-level Bluetooth APIs
+  * altos/altosui: Log averaged baro sensor data in Tm/Tn
+  * altosui: oops - lost state changes when downloading eeprom data.
+  * altos: Write a few pre-launch samples for Tm/Tn devices
+  * altosui: Add primitive bluetooth device manager UI.
+  * altosui: Create abstract AltosDevice class
+  * altosui: Make AltosBTDevice implement AltosDevice interface
+  * altosui: Make bluetooth dialog modal
+  * altosui: Use persistent list of bluetooth devices for device dialogs
+  * altos: Add delays to bt startup sequence
+  * altosui: Wait two seconds after bluetooth connect XXX
+  * altos: Solidify BT connections
+  * altos: Simplify BT communications
+  * altos: Remove bt debug command
+  * altos: remove BT logging code
+  * altosui: Eliminate ao_cmd_filter hook
+  * altosui: Make flight data download work through TeleBT
+  * altos: add telebt-v0.0 Makefile
+  * altosui: Separate out flash debug code to separate thread
+  * altosui: Fix TeleBT name in flight monitor title
+  * altosui: Display reader name (usually the device) when an I/O error occurs
+  * altosui: Move AltosIgniteUI device open out of Swing thread
+  * altosui: Fix BT manage dialog so that the device lists resize
+  * altos: Add preliminary telebt v0.1 defines
+
+  [ Bdale Garbee ]
+  * first cut at a telebt turn on script
+
+  [ Keith Packard ]
+  * altos: Add telebt-v0.1 to Makefile
+  * altos: Use USART configuration 1 with flow control for TBT
+  * altos: Fix BT link status pin for real TBT hardware
+  * altos: pull TBT v0.1 ser_reset line low
+  * altos: Add beeper to TBT v0.1
+  * altos: Debugging TBT issues -- check pin configuration after boot
+  * altos: Initialize beeper for telebt
+  * altos: Hook up the P1 ISR for TeleBT v0.1 bt_link line
+  * altos: clear CPU port 1 interrupt flag when handled
+  * Revert "altos: Debugging TBT issues -- check pin configuration after boot"
+  * Switch version to 0.9.4
+  * altosui: Handle old TeleDongle receiving kalman telemetry packets
+  * altos: Rename telemetry to telemetry_orig
+  * altos: Add arbitrary telemetry packet monitoring
+  * altos: Add checksum to TELEM output lines
+  * altos: Start adding new telemetry frame definitions
+  * altos: ao_radio_recv needs byte count *including* rssi and status
+  * altosui: Support raw telemetry from TeleDongle
+  * doc: Add telemetry format description
+  * doc: Complete initial telemetry description
+  * doc: Fix a few minor telemetry doc mistakes
+  * Version strings must be < 8 bytes long
+  * altos: teledongle does not need ao_packet_slave.c
+  * altos: Shrink const space in ao_config
+  * altos: Add sat info to GPS report command
+  * altos: Shrink help text
+  * altos: Add split telemetry code
+  * altos: Complete new telemetry switchover
+  * altosui: Parse remaining standard telemetry packets
+  * doc: Chang Config and Location packets
+  * altos: Adapt to changes in telemetry Configuration packet
+  * doc: Add section about TeleDongle USB line format
+  * altosui: Elide nul bytes at end of telemetry string values
+  * altosui: Elide missing values from graphs
+  * altosui: Add main/drogue voltages to default graph
+  * altosui: Remove debug printf.
+  * altosui: Compress telemetry records marked with the same time
+  * altos: Shrink ao_cmd_put16, ao_cmd_hex and ao_cmd
+  * altos: Shrink ao_config_callsign_set
+  * altos: Shrink ao_add_task by rolling up a memset loop
+  * altos: Switch ao_gps_skytraq and ao_gps_sirf __xdata to __pdata
+  * altos: Switch ao_ignite and ao_gps_sirf __xdata to __pdata
+  * altos: Switch ao_log.c and ao_log_big.c __xdata to __pdata
+  * altos: Switch ao_report.c __xdata to __pdata
+  * altos: Switch ao_rssi.c __xdata to __pdata
+  * altos: Switch ao_sample.c __xdata to __pdata
+  * altos: Switch ao_serial.c __xdata to __pdata
+  * altos: Switch ao_stdio.c __data to __pdata
+  * altos: Switch ao_telemetry.c __xdata to __pdata
+  * altos: Switch ao_usb.c __xdata to __pdata
+  * altos: Switch const for __code in struct ao_cmds
+  * altos: switch ao_cmd __xdata to __pdata
+  * altos: Switch ao_config.c __xdata to __pdata
+  * altos: Switch ao_dbg.c __xdata to __pdata
+  * altos: Switch ao_flight and ao_flight_nano __xdata to __pdata
+  * altos: Switch flash drivers __xdata to __pdata
+  * altos: Switch Tm and Tn to common telemetry code
+  * altos: Remove ao_telemetry_orig.c and ao_telemetry_tiny.c
+  * altos: Ensure low-rate telem packets interleave with sensor telem packets
+  * altos: product defines are always in ao_product.h
+  * altosui: Build device constants into .java code
+  * altosui: Don't show missing igniter and gps values
+  * altos: new versions of sdcc require __ prefixes for custom keywords
+  * Set version to 0.9.4.3 for Bdale 2011-7-16 flights
+  * altosui: Start adding support for scanning radio for available devices
+  * altosui: Pop up monitor window from scan dialog
+  * altosui: Remove debugging printf from AltosLog
+  * altosui: Configuration telemetry record includes flight number
+  * altosui: Finish radio scanning UI
+  * altosui: Generalize and centralize telemetry constants, parse v0.8 telemetry
+  * altosui: Initialize channel and telemetry before use in ScanUI
+  * altosui: Set 'seen' bits in legacy telemetry packet reader
+  * altosui: Add map preloading GUI
+  * altosui: Try to avoid resize weirdness with map preloading
+  * altosui: Flush telemetry lines before starting to watch for scan results
+  * altosui: Display full map preload area in view.
+  * altosui: Remove a bunch of sitemap debugging printfs
+
+  [ Anthony Towns ]
+  * altosui: Make sure degree and minute values are visible (map preload)
+
+  [ Keith Packard ]
+  * Set version to 0.9.4.4
+  * altos, altosui: Add igniter mode (dual, apogee, main)
+  * altosui: Download list of site locations for map preloading
+  * altosui: Add launch-sites.txt
+  * altosui: Add a bunch more site locations
+  * altosui: Mark preload site location with red circles (like launch)
+  * Fix NCR Pawnee location
+  * Add HARA Bragg Farms site
+  * altosui: Change continutity colors to yellow/magenta
+  * altos: Add ability to read new TELEM files to ao_flight_test
+  * altos: Average height values for landing detection
+  * altos: Reduce height averaging filter time constant
+  * altos: Require sequencing through 'main' state before landing
+  * altosui: Standard text field in flight UI needs more width (now 20)
+  * altosui: Parse accel cal from 'c s' command
+  * altosui: Simple timeouts don't work with query data
+  * altosui: Add idle monitor dialog
+  * altos/altosui: Add pad orientation configure option
+
+  [ Bdale Garbee ]
+  * update version for a Bdale build for use turning on TeleMini v1.0
+  * simplify version in last changelog entry so git-dch is less confused
+  * update changelogs for Debian build
+  * update changelogs for Debian build
+  * stop doing automatic tag push during builds
+  * build depend on bluetooth dev package
+  * clean up all existing lintian warnings
+  * rewind changelog for re-build of 0.9.4.5
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 08 Aug 2011 09:37:04 -0600
+
+altos (0.9.1) unstable; urgency=low
+
+  [ Keith Packard ]
+  * ao-load: fix usage message to note that '=' is required for options
+  * altos/test: Add dependencies in the Makefile for ao_flight_test
+  * altos/test: auto-configure acceleration parameters from the log file
+
+  [ Anthony Towns ]
+  * ao_radio: generalise setup of packet size
+  * src/ao_gps_skytraq: simplify parsing code
+  * src/ao_gps_skytraq.c: Update logging rate to 10Hz
+
+  [ Bdale Garbee ]
+  * tie bringup scripts to Bdale's bench TeleDongle
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 01 Apr 2011 20:02:12 -0600
+
+altos (0.9) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * prepare to release
+  * update changelogs for Debian build
+  * update turnon script to prefer TeleDongle as programmer
+
+  [ Keith Packard ]
+  * altos: Program default flight log max value for new boards
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 19 Jan 2011 12:46:47 -0700
+
+altos (0.8.1+81+g4ae724f) unstable; urgency=low
+
+  * we need an install target to prevent parent dir make from failing
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 18 Jan 2011 23:55:36 -0700
+
+altos (0.8.1+79+g9a5666f) unstable; urgency=low
+
+  [ Keith Packard ]
+  * doc: Don't delete telemetrum-outline.pdf
+  * doc: Add v0.9 features from altosui to documentation.
+
+  [ Bdale Garbee ]
+  * add 0.9 revision entry, with caveat about telemetry format change
+  * freshen copyright year
+
+  [ Keith Packard ]
+  * fat: Add firmware for v1.1 and docs to mac/windows/linux installers
+  * fat: Add docs to Linux package
+  * doc: Build with 'make all' from top level. Build with 'make fat'
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 18 Jan 2011 23:47:52 -0700
+
 altos (0.8.1+71+gda42f40) unstable; urgency=low
 
   [ Keith Packard ]