update changelogs for Debian build
[fw/altos] / debian / changelog
index d76c00267a74d02aaff2eedf28fb87c975976994..c2699c885c2cc1c52dfa1b0a10ea238db9ab251a 100644 (file)
@@ -1,3 +1,511 @@
+altos (0.6+373+gcf65c6b) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: rename AltosEeprom -> AltosEepromDownload, split out Altos
+    constants
+  * altosui: Capture config and version info in .eeprom files
+  * altosui: Merge gps date and time classes into gps class
+  * altosui: Clear displayed data rows as needed.
+  * altosui: Split status and info panels into separate files
+  * altosui: Explicitly initialize Altos class
+  * altosui: Split flight record out of telemetry class
+  * altosui: Compute flight state from eeprom data
+  * altosui: Add comments to Eeprom reader
+  * altos: add callsign to packet mode, increase payload to 64 bytes
+  * altosui: Start adding code to write csv files from eeprom/telem
+    files
+  * ao-dumplog: add --channel option (for use with -R option)
+  * libaltos: integrate Windows support.
+  * altosui: Select devices by USB vendor/product ID.
+  * altos: Define USB product ID in per-product Makefile.defs file
+  * altosui: Make teledongle callsign configurable
+  * altosui: Add TeleMetrum configuration
+  * altosui: Set callsign when fetching eeprom data over the air
+
+  [ Bdale Garbee ]
+  * add freetts as a build dep
+  * working on java packaging details
+
+  [ Keith Packard ]
+  * altosui: Add .ihx file reading code and stub out flashing UI
+  * altosui: Add debug dongle API, split flash UI out
+  * ao-dumplog: Fix --remote and --channel options to actually work
+  * altosui: pad TM config dialog values to avoid clipping descenders
+  * libaltos: use pipe to wake up getchar on close. use mutexes
+  * altosui: Add lots more cc1111 debug interface functions
+  * altosui: remove debug printf from AltosHexfile
+  * altosui: flush serial output before waiting for reply
+  * altosui: Remove debug printf from AltosRomconfig
+  * altosui: Finish device programming code
+  * altos: Place rom config variables in fixed location
+  * altosui: make default Manifest look for built-in freetts
+  * altosui: Separate out log file choosing dialog to share with CSV
+    generator
+  * altosui: refactor logfile chooser dialog to share more code
+  * altosui: Add ability to create CSV file from telem or eeprom files
+  * altosui: disable radio monitoring while using serial line for
+    debugging
+  * altosui: Delay mapping Flash UI until flashing actually starts
+  * altosui: fetch existing romconfig for flashing
+  * altosui: always display romconfig ui while flashing
+  * altosui: write USB serial number string while flashing
+  * altosui: flush replies from serial link when entering debug mode
+  * altos: always rebuild ao_product.c to track git version
+  * altos: print GPS state flags in GPS 'g' command
+  * altos: mark gps date written only after it gets into eeprom
+  * altosui: Move number parsing code to Altos general class
+  * altosui: Add AltosGreatCircle constructors
+  * altosui: add rssi and distance/dir from pad to CSV files
+  * altosui: AltosEepromReader was mis-setting boost tick
+  * altosui: Add support for old (version < 3) telemetry files
+  * altosui: Serial line is in UTF-8 encoding. Deal with it.
+  * altosui: When parsing saved telem files, errors shouldn't abort file
+  * altosui: Remove debug printf from AltosState.java
+  * altosui: command line args are converted to csv format
+  * altos: prepare for sdcc 2.9.1
+
+  [ Bdale Garbee ]
+  * add a dummy install target
+  * lose the prebuild hook for now while I'm fumbling
+  * add install target for libaltos
+  * add an install target for altosui
+
+  [ Keith Packard ]
+  * altosui: add elevation and range information
+
+  [ Bdale Garbee ]
+  * fix up the wrapper's path to the jar file
+  * update Debian standards version
+  * fix permissions on installed jar file, switch from ao-view to
+    altosui in
+  * install altosui man page
+  * fix man page delivery path
+  * Revert "lose the prebuild hook for now while I'm fumbling"
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 27 Aug 2010 12:40:04 -0600
+
+altos (0.6+303+gb6da90b) unstable; urgency=low
+
+  * add freetts as a build dep
+  * move to science menu
+  * working on java packaging details
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 11 Aug 2010 22:11:28 -0400
+
+altos (0.6+292+g8fc261c) unstable; urgency=low
+
+  * see if my new freetts package works
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 31 Jul 2010 10:55:21 -0600
+
+altos (0.6+290+g7877496) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: check for closed serial device before reading
+  * altosui: Remove unnecessary freetts .jar files
+  * altosui: Close serial, join reader thread, free altos_file
+  * altosui: remove debug printf
+  * libaltos: build with java src encoding UTF8
+  * altosui: construct Darwin application directory
+  * Add Mac OS X packaging bits
+  * altosui: Switch eeprom extension back to .eeprom
+  * Moved Mac OS packaging to altosui dir
+  * altosui: remove option to install to alternate volume
+  * Make altosui test script executable
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 29 Jul 2010 13:30:19 -0600
+
+altos (0.6+277+gd184819) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * fix text since TM only has one led to blink
+  * add swig as a build dep
+  * add a jdk to the build deps
+
+  [ Keith Packard ]
+  * When the EP0 IN buffer is full, don't panic, just skip sending
+    another
+  * Add libaltos which talks to USB connected altos devices
+  * Switch AltosUI to libaltos for device access
+  * Present list of altos devices in nice format
+  * Re-enable freetts
+  * Re-enable Linux support for altosui.
+  * Darwin doesn't have strndup.
+  * libaltos needs -I. on all systems
+  * libaltos: make clean remove all built files
+  * libaltos: build fat 10.5-compatible library
+  * Add Mac OS X packaging files for altosui
+  * Add application icons for Mac OS X
+  * Clean up altosui build a bit
+  * Remove directories as .class file dependencies; it makes them get
+    rebuilt all the time
+  * Java clean ups -- use varargs where possible, remove
+    AltosSerialReader
+  * Java voice reporting cleanups.
+  * Force java source encoding to UTF-8
+  * Make ao_log_data re-entrant as it is used for both sensor and GPS
+    logs
+  * altosui: Catch errors opening USB devices. Limit list to relevant
+    devices
+  * Make voice and channel menus work.
+  * Add voice test command for help in adjusting volume.
+  * Remove debug printf
+  * altosui: Add eeprom data capture function. No UI yet.
+  * altosui: Add progress bar for eeprom downloading status
+  * altosui: Fix Save flight data monitor layout, add cancel
+  * altosui: Replace device dialog. Center eeprom monitor.
+  * altosui: report rocket ground bearing at landing only if known
+  * Reset GPS ready status when GPS comes unlocked on the pad
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 29 Jul 2010 12:50:40 -0600
+
+altos (0.6+236+gcd8aa79) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Telemetry code was mis-computing RSSI
+  * Switch DBG pins to GPIO when using any debug commands. Reboot to
+    restore.
+
+  [ Bdale Garbee ]
+  * significant documentation update
+  * add build dep for sndfile
+  * reflect documentation file name change
+  * update to latest Debian standards version
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 20 Jul 2010 22:24:14 -0600
+
+altos (0.6+224+g4766b13) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * documentation updates from Bob
+
+  [ Mike Beattie ]
+  * Extension to KML output format, and minor bug fix
+
+  [ Keith Packard ]
+  * ao-view: disable radio telemetry monitoring during channel change
+  * Add special code for USB panic's.
+  * ao-postflight: was walking off state.data array
+  * Abort any in-progress radio operation when changing radio channel
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 24 Jun 2010 12:37:34 -0700
+
+altos (0.6+214+g16c4cae) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * updates including a typo fix from Bob Finch to the PKGBUILD-git.altos
+  * merge a derivative of Bob Finch's mere mortals guide as getting started
+  * merge the altusmetrum-themes package
+
+  [ Keith Packard ]
+  * Fix telemetrum.inf, tested by Adrian and Keithp
+  * Finish basic flight monitoring UI with voice using FreeTTS
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 18 May 2010 00:24:40 -0600
+
+altos (0.6+204+g6bd8513) unstable; urgency=low
+
+  * lose the quotes since they apparently aren't necessary
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 12 May 2010 19:53:58 -0600
+
+altos (0.6+202+gae6854d) unstable; urgency=low
+
+  * update desktop file for conformance with current standards
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 12 May 2010 17:04:31 -0600
+
+altos (0.6+200+g68eaaa6) unstable; urgency=low
+
+  * add initial package build scripts for Arch Linux from Bob Finch
+  * add desktop file provided by Bob Finch
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 12 May 2010 16:44:27 -0600
+
+altos (0.6+195+gcde60f1) unstable; urgency=low
+
+  * Revert "Merge remote branch 'remotes/origin/fix-reset'"
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 06 May 2010 13:59:16 -0600
+
+altos (0.6+193+g314d27a) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Don't change dbg clock while changing reset_n. Use 20ms everywhere
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 06 May 2010 12:47:51 -0600
+
+altos (0.6+190+g8b6767e) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Fix all stdio reading functions to be __critical
+  * Use ao_delay to sleep for 2 seconds instead of trying ao_sleep
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 05 May 2010 02:34:06 -0600
+
+altos (0.6+187+g8702f49) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * more text created during SFO->DEN flight
+  * initial attempt at a telemetrum turn on script .. needs work
+
+  [ Keith Packard ]
+  * Revert "Add optional 's' command to packet slave to enable/disable
+    slave mode"
+  * Disable interrupts while reading from stdin
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 05 May 2010 01:52:27 -0600
+
+altos (0.6+180+g99094f0) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Increase reset switch time to 100ms
+  * Add optional 's' command to packet slave to enable/disable slave
+    mode
+  * More ALtosUI changes
+  * Autodetect flite voice registration function
+
+  [ Bdale Garbee ]
+  * capture work done on SFO->DEN flight
+  * add some RF usage information from an email reply sent today, and
+    re-indent
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 27 Apr 2010 00:17:57 -0600
+
+altos (0.6+171+g9394393) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * wrong Yaesu model
+
+  [ Keith Packard ]
+  * Only have the slave return a packet if it received one.
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 10 Apr 2010 15:01:04 -0600
+
+altos (0.6+168+gc0ee1ae) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * INSTALL file changed by auto tools
+
+  [ Keith Packard ]
+  * libflite may forget to reference libasound
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 09 Apr 2010 00:08:24 -0600
+
+altos (0.6+164+g5c3b6e2) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Start adding java-based UI
+  * Add telemetry data parsing code
+  * Add Windows install .inf file
+  * Fix windows install file
+  * Add telem parsing code
+  * Steal C code from ao-view
+  * Display table of flight info. gps is not working yet though
+  * Fix up table formatting
+  * Fix status update
+  * Fix state updates
+  * Clean up GPS data formatting
+  * Report current gps nsat, not last locked nsat
+  * Remove GPS data missing from skytraq. Save max height/accel/speed
+  * Remove unused cell renderer class
+  * Make .jar file
+  * Use RXTX for serial comm. Add logdir preference saving
+  * Make ao_radio_idle keep trying to get the radio to idle.
+  * Don't abort the radio when enabling telemetry monitoring
+  * Clean up some altosui comments
+  * Switch TeleMetrum from v0.2 to v1.0
+  * Add Linux device discovery
+  * Interrupt running replay thread when starting another replay
+  * serial port read function cannot be interrupted. poll every 1 second
+  * TD reports "not-connected" when GPS has 0 sats
+  * Tasks may move in task structure as a result of ao_exit
+  * Enable telemetry monitoring
+  * Use 16-bit flite voice (which appears to have changed symbols
+    recently)
+  * When changing RESET line, delay 20ms
+
+  [ Bdale Garbee ]
+  * choose a better set of docbook xsl files
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 08 Apr 2010 19:56:27 -0600
+
+altos (0.6+131+g6629ec5) unstable; urgency=low
+
+  * lose the url entirely for now
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 08 Apr 2010 12:43:01 -0600
+
+altos (0.6+129+g934434f) unstable; urgency=low
+
+  * fix typo in url
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 08 Apr 2010 12:41:38 -0600
+
+altos (0.6+127+g05ad583) unstable; urgency=low
+
+  * need another build dep
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 08 Apr 2010 12:35:04 -0600
+
+altos (0.6+125+g8f1d47e) unstable; urgency=low
+
+  * make lintian happy
+  * tweak copyright assertion
+  * crudely incorporate "day in the life" info from web page
+  * rewrite urls in docbook format
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 08 Apr 2010 12:28:04 -0600
+
+altos (0.6+119+g00f49c8) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * update changelogs for Debian build
+  * move gbp.conf into debian/
+  * initial harness for documentation
+  * fix typo
+
+  [ Keith Packard ]
+  * Round radio calibration value instead of truncating
+  * Document the ao-dumplog '--remote' flag for radio-link downloads
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 30 Mar 2010 23:19:15 -0600
+
+altos (0.6+108+g6e61170) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Need to duplicate new altitude conversion code in aoview.
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 04 Mar 2010 17:33:27 -0700
+
+altos (0.6+106+ga1478f6) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Add ao_radio_xmit to help test boards without flashing them.
+  * Allow product names to have suffixes (like board revisions)
+  * Fix and document the ao-rawload --run flag
+  * Add LED test
+  * Leave .ihx files in the build directory too - easier to debug that way
+  * Eliminate deadlock when writing config from radio link
+  * Fix up LED colors for each product.
+  * Add .gitignore for ao-bringup
+
+  [ Bdale Garbee ]
+  * create a turn on script for lighting up TeleDongle v0.2 boards
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 27 Feb 2010 17:35:32 -0700
+
+altos (0.6+95+g2f45953) unstable; urgency=low
+
+  * update changelogs for Debian build
+  * conditionalize use of git on executability of /usr/bin/git binary
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 24 Feb 2010 17:30:00 -0700
+
+altos (0.6+88+gdeccc10) unstable; urgency=low
+
+  * add gawk as a build dependency since strtonum is a gawk extension
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 24 Feb 2010 16:44:35 -0700
+
+altos (0.6+86+g2491282) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Disable monitor mode before attempting radio test.
+  * Ensure that ao_alarm waits at least the specified time
+  * Remove dbg driver code from telemetrum/teledongle
+  * Add AT45DBxx1D driver
+  * Remove green LED and temp sensor from v0.2 code
+  * Add at45db161d.h header file for new flash part.
+  * Add 'f' command to display flash status register contents
+  * Dump more flash parameters for the flash_status command
+  * Dump config block from read/write config and flash_status commands
+  * Don't set ao_flash_setup_done until we're actually done.
+  * Remove flash debugging printfs
+  * Add simple gps dump command 'g'
+  * Force idle mode by shorting the SPI clock to ground at boot time.
+  * Switch to using internal cc1111 temperature sensor
+  * Missing ao_mutex_put in gps_dump
+  * Compute daytime using GPS as time base
+  * Pull in a bit more data for filtering the start of the boost
+  * Log GPS data on pad after boost detect.
+  * Change barometer conversion code to shrink conversion table
+  * Change altos build process to support per-product compile-time
+    changes
+  * Update .gitignore files
+  * Quiet make output.
+  * Add back stack size checking to altos linking phase
+  * Must install .map files for ao-load to work
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 24 Feb 2010 14:53:01 -0700
+
+altos (0.6+60+g10d1bbc) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Use ao_radio_get/ao_radio_put in packet code.
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 19 Dec 2009 13:53:32 -0700
+
+altos (0.6+58+gbbb152c) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Re-order config values. Change frequency to cal
+  * Allow radio calibration to be set from ao-load
+  * Add --cal to man page
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 19 Dec 2009 12:05:26 -0700
+
+altos (0.6+53+gcd49847) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Remove send_serial and serial_baud commands.
+  * Make ao_cmd_decimal produce both 32 and 16 bit values.
+  * Add radio calibration configuration.
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 05 Dec 2009 11:02:49 -0700
+
+altos (0.6+49+g9a1d7dd) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Change default callsign to "N0CALL"
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 04 Dec 2009 21:01:55 -0700
+
+altos (0.6+47+g4053309) unstable; urgency=low
+
+  * fix absolute path in debian/dirs, add Suggests for slim-altusmetrum
+  * change home URL in control file to be the AltOS page
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 26 Nov 2009 11:15:47 -0700
+
+altos (0.6+43+gd6ba07e) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Decode HDOP data from skytraq GPS
+  * Document ao-postflight --gps and --kml options.
+  * Make ao-postflight create filenames using input filenames.
+  * Make TD print 0000-00-00 for invalid dates.
+  * Fix --plot arg handling. Add -all option.
+  * Convert telemetry file GPS satellite information in cc_log_read
+  * Don't crash if --plot isn't passed on ao-postflight command line
+  * ao-postflight: compute barometric alt for each GPS position
+  * ao-postflight: don't try to use missing gps sat data
+  * Automatically extract flight number for eeprom and telem filenames.
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 22 Nov 2009 10:18:26 -0700
+
+altos (0.6+32+g87e6f3e) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * fix typo in comment
+
+  [ Keith Packard ]
+  * Reduce igniter firing time from 500ms to 50ms.
+  * Add GPS date/time output to ao-postflight.
+  * Eliminate SiRF state values from ao-view.
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 20 Nov 2009 13:18:06 -0700
+
 altos (0.6+27+gb0d7e3f) unstable; urgency=low
 
   [ Keith Packard ]