update changelogs for Debian build
[fw/altos] / debian / changelog
index 8f823b15208e9196550070b8a69e6aadfcd83877..63d75356cdbf6364fed6cfa77d2adce53264c556 100644 (file)
@@ -1,3 +1,206 @@
+altos (0.9.1) unstable; urgency=low
+
+  [ Keith Packard ]
+  * ao-load: fix usage message to note that '=' is required for options
+  * altos/test: Add dependencies in the Makefile for ao_flight_test
+  * altos/test: auto-configure acceleration parameters from the log file
+
+  [ Anthony Towns ]
+  * ao_radio: generalise setup of packet size
+  * src/ao_gps_skytraq: simplify parsing code
+  * src/ao_gps_skytraq.c: Update logging rate to 10Hz
+
+  [ Bdale Garbee ]
+  * tie bringup scripts to Bdale's bench TeleDongle
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 18 Feb 2011 23:55:58 -0700
+
+altos (0.9) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * prepare to release
+  * update changelogs for Debian build
+  * update turnon script to prefer TeleDongle as programmer
+
+  [ Keith Packard ]
+  * altos: Program default flight log max value for new boards
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 19 Jan 2011 12:46:47 -0700
+
+altos (0.8.1+81+g4ae724f) unstable; urgency=low
+
+  * we need an install target to prevent parent dir make from failing
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 18 Jan 2011 23:55:36 -0700
+
+altos (0.8.1+79+g9a5666f) unstable; urgency=low
+
+  [ Keith Packard ]
+  * doc: Don't delete telemetrum-outline.pdf
+  * doc: Add v0.9 features from altosui to documentation.
+
+  [ Bdale Garbee ]
+  * add 0.9 revision entry, with caveat about telemetry format change
+  * freshen copyright year
+
+  [ Keith Packard ]
+  * fat: Add firmware for v1.1 and docs to mac/windows/linux installers
+  * fat: Add docs to Linux package
+  * doc: Build with 'make all' from top level. Build with 'make fat'
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 18 Jan 2011 23:47:52 -0700
+
+altos (0.8.1+71+gda42f40) unstable; urgency=low
+
+  [ Keith Packard ]
+  * doc: Add telemetrum mounting template in svg and pdf forms
+
+  [ Mike Beattie ]
+  * Re-order and re-arrange eeprom download dialog
+  * Convert EepromSelect dialog to use a GridBag
+  * Close serial port if Download/Delete dialog is cancelled.
+
+  [ Keith Packard ]
+  * altosui: Reset eeprom download instance variables before reading
+    flight
+  * altosui: Make serial debug more complete and accurate
+  * altosui: Use long input flush timeout when remote.
+  * altosui: Remove debug message when eeprom downloads are complete.
+  * altosui: Ensure serial device is closed after eeprom download
+    finishes
+  * altosui: Require 4 sats to light up the 'GPS locked' light.
+  * doc: inkscape tracks the filename inside the document
+  * altos: TELEMETRY PROTOCOL CHANGE. Switch to 16-bit serial numbers.
+  * altos: Flush log when full
+
+  [ Anthony Towns ]
+  * altos: Restructure skytraq NMEA parsing code to save some space
+
+  [ Keith Packard ]
+  * altos: average 512 accel/baro samples at startup instead of 1000
+
+  [ Mike Beattie ]
+  * altos: Added check for an accel value above 1.5g
+  * altos: Added check for out of bounds accel
+
+  [ Keith Packard ]
+  * altos: Add DATA_TO_XDATA to linux test harness
+  * altosui: Remove spurious colons from eeprom selection headers
+
+  [ Mike Beattie ]
+  * Rework invalid accel cal detection code
+
+  [ Keith Packard ]
+  * altos: Auto-calibrate linux-based flight testing code
+  * altos: Ensure flight code gets first crack at new ADC data
+  * altos: Sample the accelerometer reference voltage on v1.1 boards
+  * altos: Optimize fetching of ADC data in flight code
+  * altos: Use 5V reference data to correct accelerometer measurements.
+  * doc: Remove mention of ao_wake_task
+
+  [ Bdale Garbee ]
+  * update documentation to reflect reality that modifying a board for
+    separate pyro battery is not trivial
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 18 Jan 2011 17:26:33 -0700
+
+altos (0.8.1+42+g646e192) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: Show dialog after successful delete or when no flights
+  * altosui: Ensure serial line is flushed after disabling remote link
+  * altosui: Add preference for serial debugging.
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 14 Jan 2011 18:00:51 -0700
+
+altos (0.8.1+37+g97b1ca9) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altos: Add configuration parameter for maximum flight log size
+  * altos: support storage of multiple flights.
+  * altos: Speed up at45 and 25lc erase speeds
+  * altos: white space fix
+  * altos: report flight log offsets in hex block numbers instead of
+    bytes
+  * altos: ensure erase mark is written when erasing flights
+
+  [ Anthony Towns ]
+  * altos: Optimize Morse code generation
+
+  [ Keith Packard ]
+  * altos: Check requested log max size against available space
+  * altos: Check for full log and complain
+  * altosui: Add configuration of flight log size
+
+  [ Anthony Towns ]
+  * altos: Remove unused accel_vel_mach and accel_vel_boost variables
+  * altos: Remove redundant initialization of ao_interval variables
+
+  [ Keith Packard ]
+  * altosui: Split eeprom download code apart
+  * altos: oops -- 'e' command was only showing 7 of the 8 bytes per
+    line
+  * altosui: Add support for parsing list of flights from the 'l'
+    command
+  * altosui: Add eeprom 'manage' ui to download and delete multiple
+    flights
+  * altos: check for valid flight number in ao_log_delete
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 14 Jan 2011 14:30:37 -0700
+
+altos (0.8.1+18+g408a3e0) unstable; urgency=low
+
+  [ Anthony Towns ]
+  * altosui: move maps to subdir, fix E/W mismatch
+
+  [ Keith Packard ]
+  * altos: clean up radio abort paths. Share radio code.
+  * altos: eliminate ao_wake_task
+  * windows: Add compatibility IDs to telemetrum.inf
+  * windows: Update NSIS installer file to use compatibility IDs
+  * altos: Split out SPI driver.
+  * altos: Add telemetrum-v1.1 directory
+  * altos: packet and usb i/o routines use 'char', not 'uint8_t'
+  * altos: Simplify storage API
+  * altos: Require manual flight erasing.
+  * altos: Move common storage code to ao_storage.c. Add M25P80 driver
+  * altos: Rip out 'optimization' in ao_log_scan
+  * altos: Mark end of available flight list with 'done' to make the UI
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 07 Jan 2011 00:51:41 -0700
+
+altos (0.8.1+4+gea95c06) unstable; urgency=low
+
+  * fix symlink paths in rules file
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 01 Dec 2010 00:14:24 -0700
+
+altos (0.8.1+2+gea7130e) unstable; urgency=low
+
+  * modify Debian package build to deliver one copy of background.png
+    for
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 01 Dec 2010 00:03:14 -0700
+
+altos (0.8.1) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * moved doc dir in web content to AltOS tree
+  * fix publish target in doc/Makefile
+  * fix section layering
+  * fix an Altos vs Altus typo in the docs
+  * adding Bdale's release process document to the source tree
+
+  [ Keith Packard ]
+  * windows: Add jfreechart.jar and jcommon.jar to windows install image
+  * Move "Releasing" to top level
+  * Add minimal release testing plan to Releasing
+
+  [ Bdale Garbee ]
+  * releasing 0.8.1
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 29 Nov 2010 21:46:54 -0700
+
 altos (0.8) unstable; urgency=low
 
   [ Keith Packard ]
@@ -9,8 +212,11 @@ altos (0.8) unstable; urgency=low
 
   [ Bdale Garbee ]
   * declaring 0.8 released
+  * update changelogs for Debian build
+  * update changelogs for Debian build
+  * rewind changelog to recover from stupid build failure
 
- -- Bdale Garbee <bdale@gag.com>  Sun, 28 Nov 2010 18:22:27 -0700
+ -- Bdale Garbee <bdale@gag.com>  Sun, 28 Nov 2010 18:32:12 -0700
 
 altos (0.7.1+168+gcb08bc2) unstable; urgency=low