update changelogs for Debian build
[fw/altos] / debian / changelog
index e886205eb5fe09669deb80d5a3f1ac57232ccec9..575effd217dddd167ebb78289acffe7a126d1e45 100644 (file)
@@ -1,3 +1,108 @@
+altos (0.6+43+gd6ba07e) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Decode HDOP data from skytraq GPS
+  * Document ao-postflight --gps and --kml options.
+  * Make ao-postflight create filenames using input filenames.
+  * Make TD print 0000-00-00 for invalid dates.
+  * Fix --plot arg handling. Add -all option.
+  * Convert telemetry file GPS satellite information in cc_log_read
+  * Don't crash if --plot isn't passed on ao-postflight command line
+  * ao-postflight: compute barometric alt for each GPS position
+  * ao-postflight: don't try to use missing gps sat data
+  * Automatically extract flight number for eeprom and telem filenames.
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 22 Nov 2009 10:18:26 -0700
+
+altos (0.6+32+g87e6f3e) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * fix typo in comment
+
+  [ Keith Packard ]
+  * Reduce igniter firing time from 500ms to 50ms.
+  * Add GPS date/time output to ao-postflight.
+  * Eliminate SiRF state values from ao-view.
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 20 Nov 2009 13:18:06 -0700
+
+altos (0.6+27+gb0d7e3f) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Add two-point accelerometer calibration.
+  * Remove "l" command as ao-dumplong no longer uses it
+  * Remove "d" command
+  * Remove "f" command
+  * Reformat ADC values to show all 16 bits
+  * ao_flight_test was using accel value for pressure too
+  * Pass accel calibration over telemetry stream. Telemetry data format
+    change.
+  * Add ability to dump eeprom data over radio link.
+  * In packet master, move USB flush from packet thread to echo thread
+  * In USB pollchar, wait for packet before re-checking USB out len
+  * Explicitly use USB I/O routines in packet code
+  * Flush pending input when switching to remote packet mode
+  * Stop recording in ao-dumplog after receiving an invalid block
+  * Move ao_match_word from ao_ignite.c to ao_cmd.c
+  * Add Watchdog Timer Control register definitions
+  * Add reboot command.
+  * Return radio to telemetry settings when packet system closed.
+  * ao-postflight: fix sloppy gps sat data realloc code (was crashing).
+  * Loosen tolerances for main->landed transition
+  * Provide a dummy 'uninstall' target in the src directory.
+  * Share telemetry parsing code in cc library.
+  * Enable telemetry receive in ao_view
+  * Switch order of serial/flight in ao-postflight summary
+  * Add flight number to telemetry stream.
+  * Add date to GPS data, captured from GPRMC packet.
+  * Stop using SiRF state info.
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 20 Nov 2009 11:43:56 -0700
+
+altos (0.6) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Add support for the SkyTraq GPS unit
+  * Build two versions of TM, one for SiRF, one for SkyTraq
+  * Save some DSEG space by marking cmd functions __reentrant
+  * Add ao_wake_task and ao_exit
+  * Add keyhole-markup generation for ao-postflight.
+  * Initial packet bits. Just testing transmission
+  * Add radio carrier command
+  * Wait for TX to finish sending data
+  * Add ao_alarm
+  * Remove reason from ao_dma_abort
+  * Switch packet code from timer thread to ao_alarm
+  * Use ao_radio_done to wait for TX to completely finish with packet
+  * Send SYN packet to set sequence numbers
+  * Add RFIM register
+  * Do more flushing in packet test code
+  * Use ao_alarm for ao_delay so it can be easily interrupted
+  * Poke master to speed up packet rate when things are busy
+  * No need to wakeup &ao_tick_count now
+  * Enable packet-based communcation to command processor
+  * Add more docs to the README file
+  * Disable interrupts while removing tasks from task list
+  * Add ao_usb_pollchar to ao.h
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 02 Nov 2009 16:53:45 -0700
+
+altos (0.5+90+g127c312) unstable; urgency=low
+
+  * de-version the libreadline-dev build dependency
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 02 Nov 2009 15:57:29 -0700
+
+altos (0.5+86+g2de548f) unstable; urgency=low
+
+  * automate push of updated and tagged master branch during
+    debian/rules prebuild
+  * flush repetitive junk out of debian/changelog, and update the
+    prebuild target
+  * add support for tagging git repository on each Debian package build
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 12 Oct 2009 16:54:28 -0600
+
 altos (0.5+77+gc57bd7f) unstable; urgency=low
 
   * build for Debian from git