update changelogs for Debian build
[fw/altos] / debian / changelog
index c808c50d2eb53f8d30513598ad454975370a1afb..4e9a99661793e176edd5f17f2bd1869fe1429753 100644 (file)
@@ -1,3 +1,267 @@
+altos (0.7.1+168+gcb08bc2) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: Split out flight monitoring to separate window
+  * altosui: Create buttons for main actions
+  * altosui: Fix channel setting at serial open time
+  * altosui: Fix more calls to AltosPreferences.channel()
+  * altosui: Create abstract interface for flight data display
+  * altosui: Add tab UI with 'pad' mode.
+  * altosui: Add ascent, descent and landed tabs
+
+  [ Bob Finch ]
+  * Updated PKGBUILD-git.altos
+
+  [ Keith Packard ]
+  * altos: Use grey leds when unlit - easier to see
+
+  [ Anthony Towns ]
+  * use value_font for values
+  * add --replay command line argument
+  * read preferences for --replay
+  * reduce font size for FlightInfoTable
+  * use grayled.png for off
+  * add compass bearing to voice output
+  * add compass bearing during descent
+  * add site map tab, at least for QRS launches
+  * tabs -> spaces
+  * make infotable scrollable, revert its fontsize to 14
+  * pull up maps for arbitrary locations
+  * better error behaviour if no map
+
+  [ Bdale Garbee ]
+  * first cut at instructions on how to re-flash TM and TD devices based
+    on email
+  * fold in content from Keith's email on the re-flashing subject
+
+  [ Keith Packard ]
+  * altosui: Add RF calibration to TeleMetrum config dialog
+
+  [ Anthony Towns ]
+  * AltosTelemetryReader: actually open serial port
+  * AltosSiteMap: add targeting circles around landing site
+
+  [ Bdale Garbee ]
+  * continuing to work on the docs
+
+  [ Keith Packard ]
+  * altosui: Eliminate unncessary import altosui lines
+  * altosui: Open serial device at 'new' time. Prohibit duplicate opens.
+  * altosui: Replace flight status table with labels, fix resize.
+  * altosui: With --replay option, exit when replay window is closed
+  * altosui: oops, missed a file in the previous commit
+  * altosui: eliminate menu bar, moving elements to buttons.
+  * altosui: add reboot button to telemetrum configuration UI
+
+  [ Bdale Garbee ]
+  * add a paragraph about forcing TM back to idle mode if an accel cal
+    goes badly
+
+  [ Keith Packard ]
+  * altosui: Add callsign configuration in AltosUI configuration dialog
+  * altosui: Cleanup flight UI layout
+  * altosui: Add igniter status to ascent and descent tabs
+
+  [ Anthony Towns ]
+  * altosui: tile site maps
+  * AltosSiteMapTile: autoscale to about 2 nmi per tile
+  * AltosSiteMapTile: adjust centering calculation
+  * AltosSiteMapTile: adjust scale to 1 nmi per tile
+
+  [ Keith Packard ]
+  * altosui: Add igniter ground testing code
+  * altosui: Unify datafile selection to AltosDataChooser
+  * altosui: Clean up global AltosUI configuration settings dialog
+  * doc: Add preliminary altosui documentation
+  * doc: git ignore generated doc files
+  * doc: Document the 'Flash Image' operation.
+  * altosui: Use timeouts to recover from broken packet links.
+
+  [ Bdale Garbee ]
+  * update turnon scripts to use stashed copies of stable release
+    firmware
+
+  [ Keith Packard ]
+  * altosui: switch channel selector to combo box. Shorten displayed
+    device names
+  * altosui: When switching log files, don't terminate log thread
+  * altosui: calling thread.interrupt with null thread doesn't work well
+  * altosui: Initialize display thread state in constructor instead of
+    run
+  * altosui: Fix channel changing in flight UI to actually work
+
+  [ Anthony Towns ]
+  * AltosSiteMap: add autoscroll and grabndrag scroll
+  * AltosSiteMapTile: seperate map and drawing layers
+  * AltosSiteMap: automatic fetching of map data
+  * AltosSiteMapTile: draw boost circle as well as landed
+  * AltosAscent/Descent: tidy up layout
+  * AltosDescent: switch elev from height to range
+
+  [ Keith Packard ]
+  * altosui: re-indent
+
+  [ Anthony Towns ]
+  * AltosSiteMap: major refactoring
+  * Add GrabNDrag.java
+
+  [ Keith Packard ]
+  * altosui: change descent tab formatting to four columns
+
+  [ Anthony Towns ]
+  * AltosSiteMap: be more polite about preferred size
+  * altosui: reindent
+
+  [ Keith Packard ]
+  * altosui: Rewrite info table to mix with scroll pane well. Fix
+    startup size
+
+  [ Anthony Towns ]
+  * AltosSiteMap: better gps check, lower zoom
+
+  [ Keith Packard ]
+  * altosui: Set site map flight path lines to 6 pixels anti-aliased.
+
+  [ Anthony Towns ]
+  * AltosSiteMap: explain tile size better
+  * AltosSiteMap: extend map if rocket goes far away
+  * AltosSiteMap: try to get new tile construction right
+  * AltosSiteMap: thread safe tile addition
+  * AltosSiteMap: refactor tile collection
+  * AltosSiteMap: never accept 0,0 as lat/long
+  * AltosSiteMap: limit nr of tiles to 200x200
+
+  [ Keith Packard ]
+  * altosui: When fixing eeprom gps time information, make GPS data
+    valid
+
+  [ Anthony Towns ]
+  * AltosSiteMap: ensure buffer around active tile
+  * altosui: improve sitemap scrolling behaviour
+  * altosui: keep sitemap more centred on rocket
+
+  [ Keith Packard ]
+  * altos: Add on/off modes to 'C' command
+
+  [ Bob Finch ]
+  * Added PKGBUILDs for deps into contribs
+
+  [ Keith Packard ]
+  * altosui: Close serial port when debug link fails
+  * altos: assume igniter worked.
+
+  [ Bdale Garbee ]
+  * add a rudimentary --help for command line use
+
+  [ Keith Packard ]
+  * doc: Add internal documentation for AltOS
+
+  [ Anthony Towns ]
+  * altosui: don't switch away from user selected tab
+  * altosui: sitemap uses rocket gps if no pad gps
+
+  [ Bdale Garbee ]
+  * merge Keith's AltosUI documention into "the big book"
+  * lose the placeholder on how GPS works, as it's going to be a
+
+  [ Keith Packard ]
+  * altos: remove unused variable from ao_igniter
+  * altos: Don't abort radio transmissions with ao_radio_abort
+  * altos: Make radio test command careful with the radio mutex.
+  * altosui: Make AltosSerial.flush_input keep reading while non-empty
+  * altosui: New AltosSerial.set_radio function sets channel/call
+  * altosui: Disable radio configation over packet link.
+  * altosui: Let people fire igniters that don't read as 'ready'
+  * altosui: Make sure packet mode is turned off when the connection
+    fails
+
+  [ Anthony Towns ]
+  * docs: Document altosui "Graph Data" button
+
+  [ Keith Packard ]
+  * Move altosui to the top level, placing libaltos inside it.
+
+  [ Anthony Towns ]
+  * doc: Document altosui "Site Map" tab
+
+  [ Keith Packard ]
+  * Missing change to top level Makefile to build altosui
+
+  [ Bdale Garbee ]
+  * fix missing section close in Site Map content
+  * tweak rev history
+  * manually fold in documentation work from the master branch
+
+  [ Keith Packard ]
+  * doc: Reformat altos to use sections for each function
+  * doc: Add more authors, fix URL formatting, note that AltosUI
+    actually exists
+  * doc: Rename telemetrum-doc as altusmetrum
+
+  [ Bdale Garbee ]
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 25 Nov 2010 01:10:18 -0700
+
+altos (0.7.1+36+g811ced6) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * remove the csv build dep, as that code will be abandoned
+
+  [ Keith Packard ]
+  * altosui: Remove ability to graph data in .csv files
+  * altosui: Separate out jfreechart and jcommon directories
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 06 Oct 2010 17:47:32 -0600
+
+altos (0.7.1+32+g8103432) unstable; urgency=low
+
+  * add build-dep on libcsv-java
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 06 Oct 2010 16:25:57 -0600
+
+altos (0.7.1+28+gd8a2f4c) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * make the column headers comma separated, too, so they align with the
+    data
+
+  [ Keith Packard ]
+  * altosui: set default .csv file name in file save dialog
+  * altosui: Remember directory containing firmware files
+
+  [ Anthony Towns ]
+  * Add graphing.
+  * Add JFreeChart to Makefile.am
+
+  [ Keith Packard ]
+  * altosui: Use recorded ground acceleration when reading eeprom files
+  * altosui: Write raw sensor data to .csv files
+  * altosui: Factor some UI elements into separate classes
+  * altosui: remove unused ReplayThread wrapper classes
+  * altosui: Require 4 sats for 'good' GPS data
+  * altosui: Create iterables for log file scanning. Split out display
+    threads
+  * altosui: .CSV output: add link quality, gps hdop and sat C/N0
+    numbers
+  * altosui: Deal with eeprom dates going backwards across wrap
+
+  [ Anthony Towns ]
+  * Hax0r graphing to support telem/eeprom files
+
+  [ Keith Packard ]
+  * altosui: use Altos constants in graphing code
+
+  [ Anthony Towns ]
+  * Add callsign/serial/flight to graph title
+
+  [ Keith Packard ]
+  * altosui: Add KML file export.
+
+  [ Bdale Garbee ]
+  * add build dep on jfreechart lib
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 06 Oct 2010 16:19:12 -0600
+
 altos (0.7.1) unstable; urgency=low
 
   [ Keith Packard ]
@@ -7,8 +271,12 @@ altos (0.7.1) unstable; urgency=low
     ../libaltos/.libs
   * Add --with-fat-dir configure option to publish finished stand-alone
     bits
+  * altosui: Fix telemetry file reader to handle tick count wrapping
+  * altosui: Remove debug printfs from AltosTelemetryReader
+  * altosui: Fill in time value of last Eeprom record read from file
+  * altosui: Stop parsing eeprom file after hitting 'landed' state
 
- -- Bdale Garbee <bdale@gag.com>  Thu, 09 Sep 2010 22:49:54 -0600
+ -- Bdale Garbee <bdale@gag.com>  Fri, 10 Sep 2010 00:09:02 -0600
 
 altos (0.7+96+g48f5799) unstable; urgency=low