update changelogs for Debian build
[fw/altos] / debian / changelog
index a7a66a670bb236547102faf003851ab39285d869..211cc6951d9ab30cc096848b829730df686feed3 100644 (file)
@@ -1,4 +1,423 @@
-altos (0.7.1+31+g635066c) unstable; urgency=low
+altos (0.9+2+g97f4f2e) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altos: Program default flight log max value for new boards
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 19 Jan 2011 12:26:48 -0700
+
+altos (0.9) unstable; urgency=low
+
+  * prepare to release
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 19 Jan 2011 00:05:17 -0700
+
+altos (0.8.1+81+g4ae724f) unstable; urgency=low
+
+  * we need an install target to prevent parent dir make from failing
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 18 Jan 2011 23:55:36 -0700
+
+altos (0.8.1+79+g9a5666f) unstable; urgency=low
+
+  [ Keith Packard ]
+  * doc: Don't delete telemetrum-outline.pdf
+  * doc: Add v0.9 features from altosui to documentation.
+
+  [ Bdale Garbee ]
+  * add 0.9 revision entry, with caveat about telemetry format change
+  * freshen copyright year
+
+  [ Keith Packard ]
+  * fat: Add firmware for v1.1 and docs to mac/windows/linux installers
+  * fat: Add docs to Linux package
+  * doc: Build with 'make all' from top level. Build with 'make fat'
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 18 Jan 2011 23:47:52 -0700
+
+altos (0.8.1+71+gda42f40) unstable; urgency=low
+
+  [ Keith Packard ]
+  * doc: Add telemetrum mounting template in svg and pdf forms
+
+  [ Mike Beattie ]
+  * Re-order and re-arrange eeprom download dialog
+  * Convert EepromSelect dialog to use a GridBag
+  * Close serial port if Download/Delete dialog is cancelled.
+
+  [ Keith Packard ]
+  * altosui: Reset eeprom download instance variables before reading
+    flight
+  * altosui: Make serial debug more complete and accurate
+  * altosui: Use long input flush timeout when remote.
+  * altosui: Remove debug message when eeprom downloads are complete.
+  * altosui: Ensure serial device is closed after eeprom download
+    finishes
+  * altosui: Require 4 sats to light up the 'GPS locked' light.
+  * doc: inkscape tracks the filename inside the document
+  * altos: TELEMETRY PROTOCOL CHANGE. Switch to 16-bit serial numbers.
+  * altos: Flush log when full
+
+  [ Anthony Towns ]
+  * altos: Restructure skytraq NMEA parsing code to save some space
+
+  [ Keith Packard ]
+  * altos: average 512 accel/baro samples at startup instead of 1000
+
+  [ Mike Beattie ]
+  * altos: Added check for an accel value above 1.5g
+  * altos: Added check for out of bounds accel
+
+  [ Keith Packard ]
+  * altos: Add DATA_TO_XDATA to linux test harness
+  * altosui: Remove spurious colons from eeprom selection headers
+
+  [ Mike Beattie ]
+  * Rework invalid accel cal detection code
+
+  [ Keith Packard ]
+  * altos: Auto-calibrate linux-based flight testing code
+  * altos: Ensure flight code gets first crack at new ADC data
+  * altos: Sample the accelerometer reference voltage on v1.1 boards
+  * altos: Optimize fetching of ADC data in flight code
+  * altos: Use 5V reference data to correct accelerometer measurements.
+  * doc: Remove mention of ao_wake_task
+
+  [ Bdale Garbee ]
+  * update documentation to reflect reality that modifying a board for
+    separate pyro battery is not trivial
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 18 Jan 2011 17:26:33 -0700
+
+altos (0.8.1+42+g646e192) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: Show dialog after successful delete or when no flights
+  * altosui: Ensure serial line is flushed after disabling remote link
+  * altosui: Add preference for serial debugging.
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 14 Jan 2011 18:00:51 -0700
+
+altos (0.8.1+37+g97b1ca9) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altos: Add configuration parameter for maximum flight log size
+  * altos: support storage of multiple flights.
+  * altos: Speed up at45 and 25lc erase speeds
+  * altos: white space fix
+  * altos: report flight log offsets in hex block numbers instead of
+    bytes
+  * altos: ensure erase mark is written when erasing flights
+
+  [ Anthony Towns ]
+  * altos: Optimize Morse code generation
+
+  [ Keith Packard ]
+  * altos: Check requested log max size against available space
+  * altos: Check for full log and complain
+  * altosui: Add configuration of flight log size
+
+  [ Anthony Towns ]
+  * altos: Remove unused accel_vel_mach and accel_vel_boost variables
+  * altos: Remove redundant initialization of ao_interval variables
+
+  [ Keith Packard ]
+  * altosui: Split eeprom download code apart
+  * altos: oops -- 'e' command was only showing 7 of the 8 bytes per
+    line
+  * altosui: Add support for parsing list of flights from the 'l'
+    command
+  * altosui: Add eeprom 'manage' ui to download and delete multiple
+    flights
+  * altos: check for valid flight number in ao_log_delete
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 14 Jan 2011 14:30:37 -0700
+
+altos (0.8.1+18+g408a3e0) unstable; urgency=low
+
+  [ Anthony Towns ]
+  * altosui: move maps to subdir, fix E/W mismatch
+
+  [ Keith Packard ]
+  * altos: clean up radio abort paths. Share radio code.
+  * altos: eliminate ao_wake_task
+  * windows: Add compatibility IDs to telemetrum.inf
+  * windows: Update NSIS installer file to use compatibility IDs
+  * altos: Split out SPI driver.
+  * altos: Add telemetrum-v1.1 directory
+  * altos: packet and usb i/o routines use 'char', not 'uint8_t'
+  * altos: Simplify storage API
+  * altos: Require manual flight erasing.
+  * altos: Move common storage code to ao_storage.c. Add M25P80 driver
+  * altos: Rip out 'optimization' in ao_log_scan
+  * altos: Mark end of available flight list with 'done' to make the UI
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 07 Jan 2011 00:51:41 -0700
+
+altos (0.8.1+4+gea95c06) unstable; urgency=low
+
+  * fix symlink paths in rules file
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 01 Dec 2010 00:14:24 -0700
+
+altos (0.8.1+2+gea7130e) unstable; urgency=low
+
+  * modify Debian package build to deliver one copy of background.png
+    for
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 01 Dec 2010 00:03:14 -0700
+
+altos (0.8.1) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * moved doc dir in web content to AltOS tree
+  * fix publish target in doc/Makefile
+  * fix section layering
+  * fix an Altos vs Altus typo in the docs
+  * adding Bdale's release process document to the source tree
+
+  [ Keith Packard ]
+  * windows: Add jfreechart.jar and jcommon.jar to windows install image
+  * Move "Releasing" to top level
+  * Add minimal release testing plan to Releasing
+
+  [ Bdale Garbee ]
+  * releasing 0.8.1
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 29 Nov 2010 21:46:54 -0700
+
+altos (0.8) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: Correct windows hardware IDs for nsis installer file
+  * windows: try harder to get windows install to work
+  * windows: remove some non-existent .inf file section references
+  * windows: more .inf file hacking
+  * windows: Bump .inf file version
+
+  [ Bdale Garbee ]
+  * declaring 0.8 released
+  * update changelogs for Debian build
+  * update changelogs for Debian build
+  * rewind changelog to recover from stupid build failure
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 28 Nov 2010 18:32:12 -0700
+
+altos (0.7.1+168+gcb08bc2) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: Split out flight monitoring to separate window
+  * altosui: Create buttons for main actions
+  * altosui: Fix channel setting at serial open time
+  * altosui: Fix more calls to AltosPreferences.channel()
+  * altosui: Create abstract interface for flight data display
+  * altosui: Add tab UI with 'pad' mode.
+  * altosui: Add ascent, descent and landed tabs
+
+  [ Bob Finch ]
+  * Updated PKGBUILD-git.altos
+
+  [ Keith Packard ]
+  * altos: Use grey leds when unlit - easier to see
+
+  [ Anthony Towns ]
+  * use value_font for values
+  * add --replay command line argument
+  * read preferences for --replay
+  * reduce font size for FlightInfoTable
+  * use grayled.png for off
+  * add compass bearing to voice output
+  * add compass bearing during descent
+  * add site map tab, at least for QRS launches
+  * tabs -> spaces
+  * make infotable scrollable, revert its fontsize to 14
+  * pull up maps for arbitrary locations
+  * better error behaviour if no map
+
+  [ Bdale Garbee ]
+  * first cut at instructions on how to re-flash TM and TD devices based
+    on email
+  * fold in content from Keith's email on the re-flashing subject
+
+  [ Keith Packard ]
+  * altosui: Add RF calibration to TeleMetrum config dialog
+
+  [ Anthony Towns ]
+  * AltosTelemetryReader: actually open serial port
+  * AltosSiteMap: add targeting circles around landing site
+
+  [ Bdale Garbee ]
+  * continuing to work on the docs
+
+  [ Keith Packard ]
+  * altosui: Eliminate unncessary import altosui lines
+  * altosui: Open serial device at 'new' time. Prohibit duplicate opens.
+  * altosui: Replace flight status table with labels, fix resize.
+  * altosui: With --replay option, exit when replay window is closed
+  * altosui: oops, missed a file in the previous commit
+  * altosui: eliminate menu bar, moving elements to buttons.
+  * altosui: add reboot button to telemetrum configuration UI
+
+  [ Bdale Garbee ]
+  * add a paragraph about forcing TM back to idle mode if an accel cal
+    goes badly
+
+  [ Keith Packard ]
+  * altosui: Add callsign configuration in AltosUI configuration dialog
+  * altosui: Cleanup flight UI layout
+  * altosui: Add igniter status to ascent and descent tabs
+
+  [ Anthony Towns ]
+  * altosui: tile site maps
+  * AltosSiteMapTile: autoscale to about 2 nmi per tile
+  * AltosSiteMapTile: adjust centering calculation
+  * AltosSiteMapTile: adjust scale to 1 nmi per tile
+
+  [ Keith Packard ]
+  * altosui: Add igniter ground testing code
+  * altosui: Unify datafile selection to AltosDataChooser
+  * altosui: Clean up global AltosUI configuration settings dialog
+  * doc: Add preliminary altosui documentation
+  * doc: git ignore generated doc files
+  * doc: Document the 'Flash Image' operation.
+  * altosui: Use timeouts to recover from broken packet links.
+
+  [ Bdale Garbee ]
+  * update turnon scripts to use stashed copies of stable release
+    firmware
+
+  [ Keith Packard ]
+  * altosui: switch channel selector to combo box. Shorten displayed
+    device names
+  * altosui: When switching log files, don't terminate log thread
+  * altosui: calling thread.interrupt with null thread doesn't work well
+  * altosui: Initialize display thread state in constructor instead of
+    run
+  * altosui: Fix channel changing in flight UI to actually work
+
+  [ Anthony Towns ]
+  * AltosSiteMap: add autoscroll and grabndrag scroll
+  * AltosSiteMapTile: seperate map and drawing layers
+  * AltosSiteMap: automatic fetching of map data
+  * AltosSiteMapTile: draw boost circle as well as landed
+  * AltosAscent/Descent: tidy up layout
+  * AltosDescent: switch elev from height to range
+
+  [ Keith Packard ]
+  * altosui: re-indent
+
+  [ Anthony Towns ]
+  * AltosSiteMap: major refactoring
+  * Add GrabNDrag.java
+
+  [ Keith Packard ]
+  * altosui: change descent tab formatting to four columns
+
+  [ Anthony Towns ]
+  * AltosSiteMap: be more polite about preferred size
+  * altosui: reindent
+
+  [ Keith Packard ]
+  * altosui: Rewrite info table to mix with scroll pane well. Fix
+    startup size
+
+  [ Anthony Towns ]
+  * AltosSiteMap: better gps check, lower zoom
+
+  [ Keith Packard ]
+  * altosui: Set site map flight path lines to 6 pixels anti-aliased.
+
+  [ Anthony Towns ]
+  * AltosSiteMap: explain tile size better
+  * AltosSiteMap: extend map if rocket goes far away
+  * AltosSiteMap: try to get new tile construction right
+  * AltosSiteMap: thread safe tile addition
+  * AltosSiteMap: refactor tile collection
+  * AltosSiteMap: never accept 0,0 as lat/long
+  * AltosSiteMap: limit nr of tiles to 200x200
+
+  [ Keith Packard ]
+  * altosui: When fixing eeprom gps time information, make GPS data
+    valid
+
+  [ Anthony Towns ]
+  * AltosSiteMap: ensure buffer around active tile
+  * altosui: improve sitemap scrolling behaviour
+  * altosui: keep sitemap more centred on rocket
+
+  [ Keith Packard ]
+  * altos: Add on/off modes to 'C' command
+
+  [ Bob Finch ]
+  * Added PKGBUILDs for deps into contribs
+
+  [ Keith Packard ]
+  * altosui: Close serial port when debug link fails
+  * altos: assume igniter worked.
+
+  [ Bdale Garbee ]
+  * add a rudimentary --help for command line use
+
+  [ Keith Packard ]
+  * doc: Add internal documentation for AltOS
+
+  [ Anthony Towns ]
+  * altosui: don't switch away from user selected tab
+  * altosui: sitemap uses rocket gps if no pad gps
+
+  [ Bdale Garbee ]
+  * merge Keith's AltosUI documention into "the big book"
+  * lose the placeholder on how GPS works, as it's going to be a
+
+  [ Keith Packard ]
+  * altos: remove unused variable from ao_igniter
+  * altos: Don't abort radio transmissions with ao_radio_abort
+  * altos: Make radio test command careful with the radio mutex.
+  * altosui: Make AltosSerial.flush_input keep reading while non-empty
+  * altosui: New AltosSerial.set_radio function sets channel/call
+  * altosui: Disable radio configation over packet link.
+  * altosui: Let people fire igniters that don't read as 'ready'
+  * altosui: Make sure packet mode is turned off when the connection
+    fails
+
+  [ Anthony Towns ]
+  * docs: Document altosui "Graph Data" button
+
+  [ Keith Packard ]
+  * Move altosui to the top level, placing libaltos inside it.
+
+  [ Anthony Towns ]
+  * doc: Document altosui "Site Map" tab
+
+  [ Keith Packard ]
+  * Missing change to top level Makefile to build altosui
+
+  [ Bdale Garbee ]
+  * fix missing section close in Site Map content
+  * tweak rev history
+  * manually fold in documentation work from the master branch
+
+  [ Keith Packard ]
+  * doc: Reformat altos to use sections for each function
+  * doc: Add more authors, fix URL formatting, note that AltosUI
+    actually exists
+  * doc: Rename telemetrum-doc as altusmetrum
+
+  [ Bdale Garbee ]
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 25 Nov 2010 01:10:18 -0700
+
+altos (0.7.1+36+g811ced6) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * remove the csv build dep, as that code will be abandoned
+
+  [ Keith Packard ]
+  * altosui: Remove ability to graph data in .csv files
+  * altosui: Separate out jfreechart and jcommon directories
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 06 Oct 2010 17:47:32 -0600
+
+altos (0.7.1+32+g8103432) unstable; urgency=low
 
   * add build-dep on libcsv-java