ao-tools: Split out altos symbol editing from ao-stmload
[fw/altos] / ao-tools / lib / Makefile.am
index e682f757d68d8aa85c1e22d948c99c1443704849..a03a976cd59b3f397790965ee338524975aef925 100644 (file)
@@ -2,13 +2,15 @@ noinst_LIBRARIES = libao-tools.a
 
 AM_CFLAGS=$(WARN_CFLAGS) $(LIBUSB_CFLAGS) $(GNOME_CFLAGS)
 
+libao_tools_a_uneeded = \
+       cc-log.c
+
 libao_tools_a_SOURCES = \
        ccdbg-command.c \
        ccdbg-debug.c \
        ccdbg-debug.h \
        ccdbg-flash.c \
        ccdbg.h \
-       ccdbg-hex.c \
        ccdbg-io.c \
        ccdbg-manual.c \
        ccdbg-memory.c \
@@ -16,7 +18,11 @@ libao_tools_a_SOURCES = \
        ccdbg-state.c \
        cc-analyse.c \
        cc-convert.c \
-       cc-log.c \
+       cc-dsp.c \
+       cc-integrate.c \
+       cc-mega.c \
+       cc-period.c \
+       cc-process.c \
        cc-usb.c \
        cc-usb.h \
        cc.h \
@@ -26,5 +32,21 @@ libao_tools_a_SOURCES = \
        cc-bitbang.h \
        cc-logfile.c \
        cc-telem.c \
+       cc-telemetry.c \
+       cc-telemetry.h \
        cp-usb-async.c \
-       cp-usb-async.h
+       cp-usb-async.h \
+       i0.c \
+       chbevl.c \
+       mconf.h \
+       cephes.h \
+       ao-hex.c \
+       ao-hex.h \
+       ao-editaltos.c \
+       ao-editaltos.h \
+       ao-elf.c \
+       ao-elf.h \
+       ao-selfload.c \
+       ao-selfload.h \
+       ao-verbose.c \
+       ao-verbose.h