ao-tools: Create general elf and hex library routines
[fw/altos] / ao-tools / lib / Makefile.am
index 9584e216f3c7b4290d05078d76f85aeab3580345..868b64f157de882a14f253d9e3966367ab7bf5d4 100644 (file)
@@ -1,6 +1,9 @@
 noinst_LIBRARIES = libao-tools.a
 
-AM_CFLAGS=$(WARN_CFLAGS) $(LIBUSB_CFLAGS)
+AM_CFLAGS=$(WARN_CFLAGS) $(LIBUSB_CFLAGS) $(GNOME_CFLAGS)
+
+libao_tools_a_uneeded = \
+       cc-log.c
 
 libao_tools_a_SOURCES = \
        ccdbg-command.c \
@@ -8,15 +11,36 @@ libao_tools_a_SOURCES = \
        ccdbg-debug.h \
        ccdbg-flash.c \
        ccdbg.h \
-       ccdbg-hex.c \
        ccdbg-io.c \
        ccdbg-manual.c \
        ccdbg-memory.c \
        ccdbg-rom.c \
        ccdbg-state.c \
+       cc-analyse.c \
+       cc-convert.c \
+       cc-dsp.c \
+       cc-integrate.c \
+       cc-mega.c \
+       cc-period.c \
+       cc-process.c \
        cc-usb.c \
        cc-usb.h \
+       cc.h \
+       cc-usbdev.c \
+       cc-util.c \
        cc-bitbang.c \
        cc-bitbang.h \
+       cc-logfile.c \
+       cc-telem.c \
+       cc-telemetry.c \
+       cc-telemetry.h \
        cp-usb-async.c \
-       cp-usb-async.h
+       cp-usb-async.h \
+       i0.c \
+       chbevl.c \
+       mconf.h \
+       cephes.h \
+       ao-hex.c \
+       ao-hex.h \
+       ao-elf.c \
+       ao-elf.h