ao-tools: Move ao-selfload into library
[fw/altos] / ao-tools / lib / Makefile.am
index 79972f46f4ea6465781a19e20535e1bb481b6956..5f47c08984d975e01d32033722749694a2dd3f03 100644 (file)
@@ -2,13 +2,15 @@ noinst_LIBRARIES = libao-tools.a
 
 AM_CFLAGS=$(WARN_CFLAGS) $(LIBUSB_CFLAGS) $(GNOME_CFLAGS)
 
+libao_tools_a_uneeded = \
+       cc-log.c
+
 libao_tools_a_SOURCES = \
        ccdbg-command.c \
        ccdbg-debug.c \
        ccdbg-debug.h \
        ccdbg-flash.c \
        ccdbg.h \
-       ccdbg-hex.c \
        ccdbg-io.c \
        ccdbg-manual.c \
        ccdbg-memory.c \
@@ -17,8 +19,8 @@ libao_tools_a_SOURCES = \
        cc-analyse.c \
        cc-convert.c \
        cc-dsp.c \
-       cc-log.c \
        cc-integrate.c \
+       cc-mega.c \
        cc-period.c \
        cc-process.c \
        cc-usb.c \
@@ -30,9 +32,19 @@ libao_tools_a_SOURCES = \
        cc-bitbang.h \
        cc-logfile.c \
        cc-telem.c \
+       cc-telemetry.c \
+       cc-telemetry.h \
        cp-usb-async.c \
        cp-usb-async.h \
        i0.c \
        chbevl.c \
        mconf.h \
-       cephes.h
+       cephes.h \
+       ao-hex.c \
+       ao-hex.h \
+       ao-elf.c \
+       ao-elf.h \
+       ao-selfload.c \
+       ao-selfload.h \
+       ao-verbose.c \
+       ao-verbose.h