altosdroid: update to latest google play services
[fw/altos] / altosdroid / Makefile.am
index d21cacd87558c6227a69409875cafd9bc50d07ec..c4bc5b9320c4fc2ea64fdaa74b12b4701831748c 100644 (file)
@@ -72,15 +72,16 @@ bin/AltosDroid-debug.apk: $(SRC) $(ALTOSLIB) $(SUPPORT_V4) $(GOOGLE_PLAY_SERVICE
 bin/AltosDroid-release-unsigned.apk: $(SRC) $(ALTOSLIB) $(SUPPORT_V4) $(GOOGLE_PLAY_SERVICES_LIB)
        ant release
 
-sign:
-       jarsigner -keystore release.keystore \
+release: bin/AltosDroid-release-unsigned.apk
+       jarsigner -sigalg SHA1withDSA -digestalg SHA1 \
+          -keystore release.keystore \
           -signedjar bin/AltosDroid-release-signed.apk \
           bin/AltosDroid-release-unsigned.apk AltosDroid
-       $(SDK)/tools/zipalign -f 4 \
+       $(ZIPALIGN) -f 4 \
           bin/AltosDroid-release-signed.apk \
           bin/AltosDroid-release.apk
 
-clean: $(GOOGLE_PLAY_SERVICES_LIB)
+clean-local: $(GOOGLE_PLAY_SERVICES_LIB)
        ant clean
        rm -rf $(EXT_LIBDIR)
        rm -f $(DRAWABLES)
@@ -88,7 +89,8 @@ clean: $(GOOGLE_PLAY_SERVICES_LIB)
 
 else
 
-clean:
+clean-local:
 
 endif
 
+clean: clean-local