altoslib: Support binary reading/writing in AltosLink
[fw/altos] / altosdroid / Makefile.am
index d21cacd87558c6227a69409875cafd9bc50d07ec..0473c17a85cad887e79b4757eedb67f5db37a8e2 100644 (file)
@@ -72,15 +72,15 @@ bin/AltosDroid-debug.apk: $(SRC) $(ALTOSLIB) $(SUPPORT_V4) $(GOOGLE_PLAY_SERVICE
 bin/AltosDroid-release-unsigned.apk: $(SRC) $(ALTOSLIB) $(SUPPORT_V4) $(GOOGLE_PLAY_SERVICES_LIB)
        ant release
 
-sign:
+release: bin/AltosDroid-release-unsigned.apk
        jarsigner -keystore release.keystore \
           -signedjar bin/AltosDroid-release-signed.apk \
           bin/AltosDroid-release-unsigned.apk AltosDroid
-       $(SDK)/tools/zipalign -f 4 \
+       $(ZIPALIGN) -f 4 \
           bin/AltosDroid-release-signed.apk \
           bin/AltosDroid-release.apk
 
-clean: $(GOOGLE_PLAY_SERVICES_LIB)
+clean-local: $(GOOGLE_PLAY_SERVICES_LIB)
        ant clean
        rm -rf $(EXT_LIBDIR)
        rm -f $(DRAWABLES)
@@ -88,7 +88,8 @@ clean: $(GOOGLE_PLAY_SERVICES_LIB)
 
 else
 
-clean:
+clean-local:
 
 endif
 
+clean: clean-local