Merge remote branch 'origin/buttonbox' into buttonbox
[fw/altos] / contrib / arch-linux / PKGBUILD-git.sdcc_patched
1 # $Id: PKGBUILD 23526 2010-08-12 12:59:41Z spupykin $
2 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Maintainer: Jose Negron <josenj.arch@mailnull.net>
4 # Patched w/ keith packard's patch for altos - RJF 26-aug-10
5
6 pkgname=sdcc
7 pkgver=2.9.0
8 pkgrel=2_patched
9 pkgdesc="Retargettable ANSI C compiler (Intel 8051, Maxim 80DS390, Zilog Z80 and the Motorola 68HC08)"
10 arch=('i686' 'x86_64')
11 license=('GPL')
12 depends=('bash' 'gcc-libs')
13 makedepends=('gputils' 'flex' 'bison' 'patch')
14 provides=('sdcc')
15 conflicts=('sdcc')
16 url="http://sdcc.sourceforge.net/"
17 options=(!strip)
18 #Patch file was taken from https://bugzilla.redhat.com/show_bug.cgi?id=488217
19 source=(http://downloads.sourceforge.net/sourceforge/sdcc/$pkgname-src-$pkgver.tar.bz2
20         http://aur.archlinux.org/packages/$pkgname/$pkgname/$pkgname-$pkgver.patch
21         new.patch)
22 md5sums=('a6151ed328fd3bc48305ffbc628dc122'
23          '35313a8edca4f2c8a03ad57036da4e62'
24          '65612bb094e719713bc477efd6000672')
25
26 build() {
27   cd $srcdir/$pkgname
28   patch -p1 -i ../$pkgname-$pkgver.patch
29   patch -p0 -i ../new.patch
30   ./configure --prefix=$pkgdir/usr
31   make
32   make install
33   strip $pkgdir/usr/bin/* || true
34 }