minimize the rules file
[debian/yforth] / debian / rules
index f1beb4e3bdfe867e73e173e83eea44f77cfe9913..f2244f75621b2d19d32583c17caead8b4641c262 100755 (executable)
@@ -1,58 +1,6 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 
-#      WARNING - the makefile for this package is not SMP-safe!  Don't try
-#              to build this package with 'make -j'
-
-# Uncomment this to turn on verbose mode.
 export DH_VERBOSE=1
 
-build: build-stamp
-build-stamp:
-       dh_testdir
-       $(MAKE)
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       -$(MAKE) clean
-       dh_clean
-
-# Build architecture-independent files here.
-binary-indep: build
-
-# Build architecture-dependent files here.
-binary-arch: build
-#      dh_testversion
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       install -g root -m 755 -o root yforth debian/tmp/usr/bin/yforth
-
-       dh_installdocs
-       dh_installexamples
-       dh_installmenu
-#      dh_installinit
-       dh_installcron
-       dh_installmanpages
-#      dh_undocumented
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-#      dh_makeshlibs
-       dh_md5sums
-       dh_builddeb
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+%:
+       dh $@