minimize the rules file
[debian/yforth] / debian / rules
index 6f116eaeccfc80b934638eac1b957a5f16f80f21..f2244f75621b2d19d32583c17caead8b4641c262 100755 (executable)
@@ -1,52 +1,6 @@
 #!/usr/bin/make -f
 
-#      WARNING - the makefile for this package is not SMP-safe!  Don't try
-#              to build this package with 'make -j'
-
 export DH_VERBOSE=1
 
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-build-stamp:
-       dh_testdir
-       $(MAKE)
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       [ ! -f Makefile ] || $(MAKE) clean
-       dh_clean
-
-binary-indep: build
-
-binary-arch: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       install -g root -m 755 -o root yforth debian/yforth/usr/bin/yforth
-
-       dh_installdocs
-       dh_installexamples
-       dh_installmenu
-       dh_installcron
-       dh_installman *.1
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary build-arch build-indep
+%:
+       dh $@