0.2.1 includes my 0.2.0 patches, prepare to upload
[debian/yforth] / debian / patches / makefile-support-hardening
diff --git a/debian/patches/makefile-support-hardening b/debian/patches/makefile-support-hardening
deleted file mode 100644 (file)
index 51d26a7..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 5e0fddb..301fd02 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,4 +1,3 @@
--OPTIMIZE = -O2
- CC = gcc
- MATHLIB = -lm
-@@ -13,16 +12,16 @@ INCLUDES = block.h blocke.h config.h core.h coree.h defaults.h double.h \
-       string.h tools.h toolse.h udio.h ver.h ycore.h yforth.h 
- yforth: div.h $(OBJECTS)
--      $(CC) -o yforth $(OBJECTS) $(MATHLIB)
-+      $(CC) -o yforth $(LDFLAGS) $(OBJECTS) $(MATHLIB)
- div.h: div
-       ./div 
-       
- div: division.c
--      $(CC) -o div division.c
-+      $(CC) -o div $(CFLAGS) $(CPPFLAGS) division.c
- .c.o:          
--      $(CC) -c -o $@ $(OPTIMIZE) $<
-+      $(CC) -c -o $@ $(CFLAGS) $(CPPFLAGS) $<
- clean:
-       rm -f *.o yforth div.h div