modify upstream makefile to allow hardening build flags to apply
[debian/yforth] / Makefile
index 5e0fddb08bc741a61c4222653e91f7ff79a7e358..301fd02cc454a0d92058e20903b64196ef8c5e84 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,3 @@
-OPTIMIZE = -O2
 CC = gcc
 MATHLIB = -lm
 
@@ -13,16 +12,16 @@ INCLUDES = block.h blocke.h config.h core.h coree.h defaults.h double.h \
        string.h tools.h toolse.h udio.h ver.h ycore.h yforth.h 
 
 yforth: div.h $(OBJECTS)
-       $(CC) -o yforth $(OBJECTS) $(MATHLIB)
+       $(CC) -o yforth $(LDFLAGS) $(OBJECTS) $(MATHLIB)
 
 div.h: div
        ./div 
        
 div: division.c
-       $(CC) -o div division.c
+       $(CC) -o div $(CFLAGS) division.c
 
 .c.o:   
-       $(CC) -c -o $@ $(OPTIMIZE) $<
+       $(CC) -c -o $@ $(CFLAGS) $<
 
 clean:
        rm -f *.o yforth div.h div