dump test results into build log on test failure to help with #837351
[debian/tar] / debian / rules
index 6ed8fe2060cf0ee32c0e48594079e16f33de9433..7c2f21c0ca2b40c85364f7ca9332ebba08fea9c1 100755 (executable)
@@ -49,7 +49,7 @@ ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
          echo "Sorry, but the test suite is not designed to be run as root."; \
          exit 1 ;\
        fi
-       $(MAKE) check
+       $(MAKE) check || { cat tests/testsuite.log; false; }
 endif
 endif