update for changes in new version
authorBdale Garbee <bdale@gag.com>
Tue, 8 Sep 2009 21:25:54 +0000 (15:25 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 8 Sep 2009 21:25:54 +0000 (15:25 -0600)
debian/copyright
debian/rules
hd-parms.h [new file with mode: 0644]
std-parms.h [new file with mode: 0644]

index 2e0c30340effcfd552dd09834ecae1c3720573f7..820fb3f63e97a586c704b50eb412a7dc540cfaee 100644 (file)
@@ -7,9 +7,12 @@ Upstream Author: John A Magliacane, KD2BD
 
 Copyright:
 
-       Copyright John A. Magliacane, KD2BD 1997-2002
+       Copyright John A. Magliacane, KD2BD 1997-2009
 
-       GPL
+This program is free software; you can redistribute it and/or modify it 
+under the terms of the GNU General Public License as published by the
+Free Software Foundation; either version 2 of the License or any later
+version.
 
 On Debian GNU/Linux systems, the complete text of the GNU General Public
 License can be found in the `/usr/share/common-licenses' directory.
index 7f47a43bccc7e9a68b92b7005dba622bed18e084..d0413e99184398efff3abc791da6124630e37847 100755 (executable)
@@ -8,7 +8,8 @@
 build: build-stamp
 build-stamp: 
        dh_testdir      
-       g++ -Wall -O3 -lm -lbz2 -fomit-frame-pointer itm.cpp splat.cpp -o splat
+       g++ -Wall -O3 -fomit-frame-pointer -ffast-math itm.cpp splat.cpp -lm -lbz2 -o splat
+       g++ -Wall -O3 -fomit-frame-pointer -ffast-math itm.cpp splat.cpp -lm -lbz2 -o splat-hd
        (cd utils ; \
                cc -Wall -O3 -fomit-frame-pointer citydecoder.c -o citydecoder)
        (cd utils ; \
@@ -17,13 +18,16 @@ build-stamp:
                cc -Wall -O3 -lbz2 -fomit-frame-pointer srtm2sdf.c -o srtm2sdf)
        (cd utils ; \
                cc -Wall -O3 -lz -fomit-frame-pointer fontdata.c -o fontdata)
+       (cd utils ; \
+               cc -Wall -O3 -fomit-frame-pointer -lm bearing.c -o bearing)
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp splat
-       rm -f utils/srtm2sdf utils/fontdata utils/citydecoder utils/usgs2sdf
+       rm -f build-stamp splat splat-hd
+       rm -f utils/srtm2sdf utils/fontdata utils/citydecoder utils/usgs2sdf \
+               utils/bearing
        dh_clean
 
 install: build
@@ -32,10 +36,12 @@ install: build
        dh_clean -k
        dh_installdirs
        cp splat $(CURDIR)/debian/splat/usr/bin
+       cp splat-hd $(CURDIR)/debian/splat/usr/bin
        cp utils/citydecoder $(CURDIR)/debian/splat/usr/bin
        cp utils/usgs2sdf $(CURDIR)/debian/splat/usr/bin
        cp utils/srtm2sdf $(CURDIR)/debian/splat/usr/bin
        cp utils/fontdata $(CURDIR)/debian/splat/usr/bin
+       cp utils/bearing $(CURDIR)/debian/splat/usr/bin
        cp docs/english/man/splat.man \
                $(CURDIR)/debian/splat/usr/share/man/man1/splat.1
 
diff --git a/hd-parms.h b/hd-parms.h
new file mode 100644 (file)
index 0000000..5c100a5
--- /dev/null
@@ -0,0 +1,20 @@
+//
+// Parameters for 1 arc-second high resolution mode of operation
+// Generated for Debian packaging by bdale@gag.com on 2009-09-08
+//
+
+#define HD_MODE 1
+
+// how big an area to allow processing in 1 arc-second mode
+//     1 x 1 Degrees  ---------    52 Megabytes minimum RAM
+//     2 x 2 Degrees  ---------   225 Megabytes minimum RAM
+//     3 x 3 Degrees  ---------   468 Megabytes minimum RAM
+//     4 x 4 Degrees  ---------   855 Megabytes minimum RAM
+//     5 x 5 Degrees  ---------  1305 Megabytes minimum RAM
+//     6 x 6 Degrees  ---------  1890 Megabytes minimum RAM
+//     7 x 7 Degrees  ---------  2565 Megabytes minimum RAM
+//     8 x 8 Degrees  ---------  3330 Megabytes minimum RAM
+#define NUMDEGREES     4
+
+#define MAXPAGES (NUMDEGREES*NUMDEGREES)
+
diff --git a/std-parms.h b/std-parms.h
new file mode 100644 (file)
index 0000000..5efe0cf
--- /dev/null
@@ -0,0 +1,19 @@
+//
+// Parameters for 3 arc-second standard resolution mode of operation
+// Generated for Debian packaging by bdale@gag.com on 2009-09-08
+//
+
+#define HD_MODE 0
+
+// how big an area to allow processing in 3 arc-second mode
+//     2 x 2 Degrees  ---------   25 Megabytes minimum RAM
+//     3 x 3 Degrees  ---------   52 Megabytes minimum RAM
+//     4 x 4 Degrees  ---------   95 Megabytes minimum RAM
+//     5 x 5 Degrees  ---------  145 Megabytes minimum RAM
+//     6 x 6 Degrees  ---------  210 Megabytes minimum RAM
+//     7 x 7 Degrees  ---------  285 Megabytes minimum RAM
+//     8 x 8 Degrees  ---------  370 Megabytes minimum RAM
+#define NUMDEGREES     8
+
+#define MAXPAGES (NUMDEGREES*NUMDEGREES)
+