Makefile now handles spaces in the path (#122)
[debian/pforth] / platforms / unix / Makefile
index dae12a023ab888d914b445802bef5a0e61a25134..6bf8441edd51888e7c585be90f16e767538026ac 100644 (file)
@@ -100,7 +100,7 @@ $(PFDICAPP): $(PFINCLUDES) $(PFOBJS)
 
 # Build basic dictionary image by running newly built pforth and including "system.fth".
 $(PFORTHDIC): $(PFDICAPP)
-       wd=$$(pwd); (cd $(FTHDIR); $${wd}/$(PFDICAPP) -i system.fth)
+       wd=$$(pwd); (cd $(FTHDIR); "$${wd}/$(PFDICAPP)" -i system.fth)
        (cd $(FTHDIR); cat pforth.dic; rm -f pforth.dic) > $@
 
 $(PFDICDAT): $(PFORTHDIC) $(PFDICAPP)