Merge branch 'upstream'
[debian/pax] / Makefile
index 8a94849ac9695880c580f594255fb173c84185e7..72f59b1338500ef4798c0e2c33ab635134842d43 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,16 @@
+#      $OpenBSD: Makefile,v 1.10 2001/05/26 00:32:20 millert Exp $
+
+# To install on versions prior to BSD 4.4 the following may have to be
+# defined with CFLAGS +=
+#
+# -DLONG_OFF_T Define this if the base type of an off_t is a long (and is
+#              NOT a quad).  (This is often defined in the file
+#              /usr/include/sys/types.h).
+#              This define is important, as if you do have a quad_t
+#              off_t and define LONG_OFF_T, pax will compile but will
+#              NOT RUN PROPERLY.
+#
+
 PROG=   pax
 SRCS=  ar_io.c ar_subs.c buf_subs.c cache.c cpio.c file_subs.c ftree.c\
        gen_subs.c getoldopt.c options.c pat_rep.c pax.c sel_subs.c tables.c\